It's all about the answers!

Ask a question

Reports do not keep non-heading indentation


Tali Rabetti (10112) | asked Mar 12 '17, 4:11 a.m.

When exporting a module into Doc, the indentation of non -heading artifacts is not kept, and they all printed flat. Is there any solution for that?


Comments
Donald Nong commented Mar 12 '17, 6:57 p.m.

What version? Any samples?


Tali Rabetti commented Mar 13 '17, 3:32 a.m.

version 6.0.1.
Apparently I do not have enough "reputation points" to add an image, how else can I provide a sample? in any case - it is nothing special, just non heading artifacts with hierarchy.

2 answers



permanent link
Subramanya Prasad Pilar (3.5k14) | answered Mar 13 '17, 6:24 a.m.
edited Mar 15 '17, 2:46 p.m.

You can set "style" to  dataSource/artifact/moduleContext/contextBinding/depth when isHeading == "true".
dataSource/artifact/moduleContext/contextBinding/section gives the indent level, which you can use for non headings (when isHeading != "true").
If you do not want to print section, you may set indent based on section.length (or using some other logic).


Comments
Tali Rabetti commented Mar 15 '17, 8:12 a.m. | edited Mar 15 '17, 8:14 a.m.

hi Prasad, I tried what you suggested and got awkward results, any idea why the following happened?

1. I took a clean DNGModule template from the sample templates that come with RPE. Works fine when I run it as is.
2. I changed in the non heading (isHeading!=true) paragraph either style or left indentation to dataSource/artifact/moduleContext/contextBinding/depth

the result is that the headings (isHeading==true), that previously printed fine, are now printed as "normal" style.


Subramanya Prasad Pilar commented Mar 15 '17, 2:59 p.m. | edited Mar 15 '17, 3:01 p.m.

You cannot get the exact indent by setting Left (Indentation) property as this value should be given in points.
Please try setting some value based on section as the Left Indentation for Paragraph that prints non headings. No other changes are needed.


permanent link
David Clark (173119) | answered Mar 13 '17, 8:20 a.m.

 It is also dependent on the style sheet you are using.

Your answer


Register or to post your answer.