It's all about the answers!

Ask a question

How can you include a link to a Plan in an Office Document?


Jamie Berry (14012650) | asked Feb 28 '17, 11:57 a.m.

I have a user who is trying to include a link to their RTC plan in a PowerPoint presentation.  The link is of the form: https://server:9443/ccm/web/projects/PROJECT#action=com.ibm.team.apt.viewPlan&page=com.ibm.team.apt.web.ui.plannedItems&id=_uuid



I know this is an issue with Office products, but I was hoping someone here might have a suggestion that would allow them to include the URL, other than having to right-click and use Copy Hyperlink...

Thanks,
Jamie.


Comments
Donald Nong commented Mar 02 '17, 5:03 a.m.

Do you want to open the link within PowerPoint? I don't have any problems when the link is redirected to the default browser.

2 answers



permanent link
Michelle Rivera (111) | answered Mar 08 '17, 12:15 p.m.

Hi - I too have this issue - it often occurs with Word and I just tried PowerPoint.  The issue is:
1. Copy the RTC Plan's URL from the browser's URL bar
2. Paste URL or Insert > Add hyperlink in PowerPoint
3. Run PowerPoint as a slideshow; which 'activates' the RTC Plan hyperlink
4. Click the RTC Plan hyperlink
5. Fails with:
Error! The project XXX (CM) - action=com.ibm.team.apt.viewPlan&page=com.ibm.team.apt.web.ui.plannedItems&id=xxxxxxxxxxxxxxxxxxxxx does not exist or is not accessible with your credentials. If you have JazzAdmins privileges you can investigate the problem in the Jazz Admin Web UI.

Please try the following workaround (working for me) - "URL encode" the RTC Plan's URL. I used below tool;  scroll down a little to the section "URL Encoding Functions"  http://www.w3schools.com/tags/ref_urlencode.asp

1. Clear the field, then paste the URL from Rational
2. Click 'URL Encode' button
3. Copy the resulting/new URL into PowerPoint, Word, etc


Comments
Jamie Berry commented Mar 13 '17, 4:19 p.m.

 I have tried this URL Encoding tool and it still isn't working for me.  Thank you for the suggestion.


Jamie.


permanent link
Jamie Berry (14012650) | answered Apr 06 '17, 6:26 p.m.

 I found that trying to encode the URL didn't work.  It appears to really be a problem in how Windows is handling links that authenticate with Single Sign On products, which we use at our company.  I am going to investigate more with our SSO team as the issue only occurs with links to CCM but not RQM and we have SSO on for both.  The solution I found that does work requires a registry change and I would like to solve this without pushing a registry update to all our users.  The MS Knowldge article that pointed me to the solution is: https://support.microsoft.com/en-us/help/899927/you-are-redirected-to-a-logon-page-or-an-error-page-or-you-are-prompted-for-authentication-information-when-you-click-a-hyperlink-to-a-sso-web-site-in-an-office-document?cm_mc_uid=82164841234314900338982&cm_mc_sid_50200000=1491516102


Thanks Jamie.

Your answer


Register or to post your answer.