It's all about the answers!

Ask a question

I see during ClearCase import/connector to RTC during ClearCase conntector import

Glenn Bardwell (58621527) | asked Oct 05 '12, 10:05 a.m.
edited Oct 05 '12, 10:26 a.m. by Geoffrey Clemm (30.1k33035)
The ClearCase import fails and I see the following in the log file.

     <a  few  more lines  I'll include in the post, but that makes this entry too big to save>
Caused by:
      at sun.nio.cs.StreamDecoder$ConverterSD.convertInto(

One answer

permanent link
Glenn Bardwell (58621527) | answered Oct 05 '12, 10:08 a.m.
MalformedInputExceptions are often a result of an encoding issue.
The name of the file or the directory in ClearCase VOB contains a byte sequence not legal for the given character set.

Switch the system locale to the one that can read the file name or the directory name, then reboot

You can set the proper encoding by setting the LANG env variable to the proper  value. See the steps below.

Stop the sync engine if it is running ( you can find the process by something like 'ps -ef | grep buildengine' )
Close RTC eclipse client
Set LANG environment variable in your terminal, export it. ( 'setenv LANG en_US.ISO-8859-1' or 'export LANG=en_US.ISO-8859-1' etc.)
Start RTC eclipse client from the terminal
Verify the LANG env. variable is set as expected, by 'cat /proc/<RTC eclipse client process>/environ' and find LANG var.
Go to ClearCase Sync. view, select your sync. stream and start sync. engine
Again, verify  the LANG env. variable is set as expected for the sync engine process
Run sync

For more detail see
comment 15

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.