It's all about the answers!

Ask a question

Error importing work items in 603


Andy Lapping (1834) | asked Feb 07 '17, 4:07 a.m.

I'm trying to import work items from a CSV file. The same CSV file and the same project setup worked fine in 602 - but in 603 I get the error: Attempting to get unset feature: Summary



Comments
Tobias Klein commented Oct 17 '17, 12:05 p.m. | edited Oct 17 '17, 2:31 p.m.

 Hi!


I'm having the same problem as described in the original post. Using RTC 6.0.3 with CCM iFix007.
Is there more information available by now?


Stefan Oblinger commented Oct 24 '17, 1:51 a.m. | edited Oct 24 '17, 1:52 a.m.

Hello Tobias,

yes, there is: http://www-01.ibm.com/support/docview.wss?uid=swg1PI84216

The issue should be fixed in:
- 6.0.3 iFix007
- 6.0.4 iFix003
- 6.0.5

I successfully validated the fix with 6.0.4 iFix003.

Cheers,
Stefan

2 answers



permanent link
Matt Muller (54812153) | answered Feb 07 '17, 8:16 a.m.

Andy,

Have you checked?   The CSV file for the Summary of that WI - may contain something that's causing the problem..  Also check the Excel file for that Summary.

what settings / configuration are you using for the import?..   you updating or adding etc.

Regard

Matt Muller


Comments
Ian Barnard commented Feb 07 '17, 9:38 a.m.
JAZZ DEVELOPER

 I'm trying with the same data - the error is raised after importing all the WIs, when saving the links. If I clear out all the Blocks/Depends On and Parent/Children columns then the import works fine. All the links are consistent, and the WI numbers referenced by the links don't already exist in the project.


Ian Barnard commented Feb 07 '17, 9:40 a.m.
JAZZ DEVELOPER

 I am adding, in comma-separated save of the file. I think Andy is adding too, in original tab-separated csv data as exported using eclipse client from (probably) 6.0.1 or earlier.


Ian Barnard commented Feb 07 '17, 10:28 a.m.
JAZZ DEVELOPER

The work items get created, then the error happens, and there are no links between the WIs, but the WIs are in the project. Is it possible there is a new permission in 6.0.3 that is stopping this? I tried through Eclipse and through the new web CSV import, same both ways.


permanent link
Andy Lapping (1834) | answered Feb 07 '17, 8:25 a.m.

I think this is environmental - I used my own local install of 603 and the file worked perfectly. We have an image of 603+iFix1 up on cloud concierge which is choking on the same file

Your answer


Register or to post your answer.