It's all about the answers!

Ask a question

Does anyone know why the RQM Quick Search wouldn't find a Test Suite Execution Record by its ID?

Jamie Berry (14013593) | asked Jan 19 '17, 3:58 p.m.

 We are using RQM 6.0.3 and are seeing a strange issue with one of our project areas.  They have a couple of Test Suite Execution Records that show up when they use the Execution -> Browse Test Suite Execution Records but if they try entering the ID of the record in the RQM Quick Search, nothing is found.  This project is relying on their testers being able to enter the Test Suite Execution Record IDs in the quick search to quickly get to the record for test suite execution.  Most of their records show up using the quick search, but they have reported 2 that they know are having this issue.  The options for the quick search are set to search all artifacts.  I have even tried selecting just Test Suite Execution Records and it still does not find it.  I have also tried searching by name.

Has anyone seen this and know how to resolve it?

Jamie Berry.

One answer

permanent link
Donald Nong (14.5k414) | answered Jan 19 '17, 10:14 p.m.
edited Jan 19 '17, 10:15 p.m.

You can first use RQM REST API to get the XML presentation of the said artifacts, compare them with the other working ones, and see if you can spot anything abnormal, in particular the <Identifier> and <WebId> attributes.

You can use RQM URL Utility for the same purpose and it is more user-friendly. You can download it here.

If they look no different to other artifacts, the RQM index may get corrupted and no longer in-sync with the database - Quick Search relies on the index. In this case, you may just need to rebuild the index, which requires a down time.

If you want some further assurance and/or assistance on this, please contact IBM Support.

Your answer

Register or to post your answer.