It's all about the answers!

Ask a question

Source control not showing in eclipse 4.4.1 and RTC 5.0.2/6.0.1 Linux clients


Karthik Krishnan (8594103153) | asked Apr 27 '16, 10:48 a.m.
edited May 03 '16, 8:55 a.m.
I used RTC 6.0.1 and RTC 5.0.2 P2 repo install on Eclipse 4.4.1 64bit 

Whenever I connect to RTC, I can mount Project Areas but I don't see "Source control" nor "My Repository workspaces"

I did the same on Windows and it works fine. 

I have a authorized Practitioner license so I have to rule out license issue. 

Anyone else face this issue?

Linux client

Update: Found out that this also happened in Windows and was able to fix that by following
- Download Eclipse 4.4.1 CDT Luna 64 bit
- Download IBM JDK 7
- Point the IBM JDK as VM in Eclipse.ini
- Install RTC 6.0.1 P2 repo
and it shows up the SCM part

Unfortunately the same doesn't work for Ubuntu based clients. Since I couldn't find IBM JDK for Ubuntu, I took the jdk (com.ibm.java.linux.x86_64.jdk_7.0.0.20150728.zip) which is part of RTC-Client-Eclipse4.2-repo-6.0.1.zip 
but still no SCM in Eclipse clients. 

Any idea how to get the P2 repo to RTC Luna clients?

3 answers



permanent link
Karthik Krishnan (8594103153) | answered May 10 '16, 11:45 a.m.
Ok found out the solution for this issue with the help of IBM 

- RTC plugins require some basic Eclipse packages which it tries to download during the plugin installation
- If Eclipse client isn't able to access the internet chances are these required Eclipse plugins like EMF won't be downloaded
- This will lead to Eclipse client with no SCM

Before installing the plugin make sure that Eclipse itself has access to internet, if not enable it via the network settings (in preferences).

Then proceed with the installation of the RTC plugin itself.  Unfortunately there aren't any error messages show if the mandatory plugins aren't downloaded.

I've been trying to install RTC plugin on Eclipse Cpp which doesn't have these mandatory plugins. For more: https://jazz.net/library/article/949

Note: This is valid for most Eclipse versions.





permanent link
Donald Nong (14.4k314) | answered May 06 '16, 6:37 a.m.
It works for me in my Red Hat 6 VM.


The Eclipse (not RTC) is just extremely unstable though - crashes very frequently.

Also, not sure why you said you could not find IBM JDK for Ubuntu? Wouldn't the IBM JDK for Linux work?
http://www.ibm.com/developerworks/java/jdk/linux/download.html

Comments
Karthik Krishnan commented May 09 '16, 7:38 a.m.

 Tried downloading the IBM JDK and installed the "ibm-java-x86_64-71". Installed this JRE and pointed the Eclipse to take this as VM


Installation went well but back to the same root problem. I don't see source control nor the "Pending changes" in Eclipse Views. 

I checked and the MD5 matches. I used the same P2 repo for Windows and I had same trouble. Pointing to IBM JDK for windows, I was able to solve this issue. 

Not working under Ubuntu. I don't know what I am doing wrong. NO errors are reported even to debug.   


Donald Nong commented May 09 '16, 9:17 p.m.

If no errors are reported, it sounds more like a license issue, but I assume you're using the same user on both Linux and Windows environment, right? If you can give me access to your environment, I can have a quick look at it.


Karthik Krishnan commented May 10 '16, 12:37 a.m.

 Yes. Same license. But the worst part is I don't need to login to check Jazz source control in Eclipse preferences. 


How can I give access to my env? Are you working with IBM? If so would a PMR will do?

Thank you.


Donald Nong commented May 10 '16, 1:03 a.m.

Yes. A PMR will be the way to go. You can mention this post in the PMR, since the PMR may not end up in my hands. :-)


Karthik Krishnan commented May 10 '16, 3:42 a.m.

 Thanks Donald. PMR created and waiting :-)


permanent link
Karthik Krishnan (8594103153) | answered May 04 '16, 11:17 a.m.
 Anyone? 

It's hard to find out what went wrong as there are no logs. I've been redoing the same (installing via P2 repo) for last 3 days and still same issue.


Your answer


Register or to post your answer.