It's all about the answers!

Ask a question

There is no login input field on the setup page


chen yang (1621) | asked Aug 07 '09, 8:07 a.m.
Following are my configuration:
Windows 2003 server
DB V91
WAS 6.1.0.19
LDAP ITDS V6

I installed the RTC-Standard-Server-2.0M3D1 Trial version successfully. It was expired and now i install RTC-Enterprise-Full-2.0-Win32-Local (I uninstalled and re-installed the WAS, dropped and re-created the database). The jazz.war can be installed and start successfully, but I encounter the issue: I go to the https://myhostname:9443/jazz/setup , there is no username and password input fields on the page, only a sentence "You are not authorized to access Jazz Team Server Setup".

There is no new lines added in SystemOut.log. It is the similar result when I enter https://myhostname:9443/jazz/admin, the message is "You are not authorized to access Jazz Team Server Admin UI" and there is no any input fields either.

Can anyone provide help? Thanks.

4 answers



permanent link
Christophe Elek (2.9k12921) | answered Aug 08 '09, 12:53 a.m.
JAZZ DEVELOPER
garychenyang@gmail-dot-com.no-spam.invalid (garychenyang) wrote in
news:h5h5f2$8b0$2@localhost.localdomain:

I enter https://wk09.cn.ibm.com:9443/jazz/admin, the
message is "You are not authorized to access Jazz Team Server
Admin UI" and there is no any input fields either.


If you are not prompted, I would check th esecurity setup of WAs and ensure
it is on

--
Christophe Elek
Jazz L3
IBM Software Group - Rational

permanent link
chen yang (1621) | answered Aug 09 '09, 4:54 a.m.
Christophe, Thanks for your reply. I checked the security setup of WAS, the "Test Connection" can connect successfully. And I can login the WAS console with the admin account in the LDAP, which I set in the WAS security part.

permanent link
chen yang (1621) | answered Aug 09 '09, 9:27 a.m.
I re-installed the WAS and re-configured all, and got the same result. If re-starting the jazz_war, following log in the SystemOut.log:

00000020 ApplicationMg A WSVR0200I: Starting application: jazz_war
00000020 ApplicationMg A WSVR0204I: Application: jazz_war Application build level: Unknown
00000020 WebGroup A SRVE0169I: Loading Web Module: jazz.war.
00000020 ServletWrappe I SRVE0242I: : Initialization successful.
00000020 WebApp W Error while adding servlet mapping --> /* Please set fileServingEnabled=false in the ibm-web-ext.xmi file which is under WEB-INF folder.
00000020 VirtualHost I SRVE0250I: Web Module <null> has been bound to default_host
  • .
    00000020 ApplicationMg A WSVR0221I: Application started: jazz_war
    00000020 ApplicationDe I ApplicationDeploymentController perform ApplicationDeploymentController: performing appcontexts refresh


    I check the ibm-web-ext.xmi file under Node01Cell\jazz_war.ear\jazz.war\WEB-INF, there is no " fileServingEnabled" property.

  • permanent link
    chen yang (1621) | answered Aug 10 '09, 3:10 a.m.
    Sorry, I forgot to set the user/group map in the jazz_war application. This was solved after I set it.

    Your answer


    Register or to post your answer.