It's all about the answers!

Ask a question

when I tried to save work item, I got this error message : Could not save work item. unknown action 'com.ibm.team.workitem.defectWorkflow.action.confirm'.


jane zhou (86228) | asked Mar 04 '16, 3:50 a.m.
I am new to use RTC for Change Management.
 when I tried to save work item, I got this error message : Could not save work item. unknown action 'com.ibm.team.workitem.defectWorkflow.action.confirm'.

But I have checked Work items -> Types and Attributes, I did not find any action related to com.ibm.team.workitem.defectWorkflow.action.confirm

Could anyone help me on this?

Thanks!

Best Regards,
Jane

2 answers



permanent link
Matt Muller (58312361) | answered Mar 04 '16, 4:22 a.m.

Jane,

I guess you need to look into the details of the config / some suggestions:

1. Permissions firstly (just to see what's there) - What role / restrictions are applied to that Action / State Change and it it's there?  Who can Change the State for that Action.

2. Configuration updates?  has anyone updated the Work Item > Workflow?

3. Search in the Process config > for that Action ID "com.ibm.team.workitem.defectWorkflow.action.confirm" is it there? if not what's happened

4. If you have made updates to "Workflows" and not investigated/reviewed any impacts on existing data then this may cause problems.

5. Lastly review the History of the Projects configuration to see when and if it's been removed.

Regards

Matt Muller


Comments
jane zhou commented Mar 04 '16, 5:06 a.m.

 Hi Matt,


   Thanks for your great help! Please see my answer for your suggestions as follows:
   1 permission should be fine, I configured myself as product owner
   2 I did not change workflow, and I have compared the workflow with other project which can work, no difference, 
   3 where could I find process config? sorry, I am rather new for RTC.
   4 I did not update workflows
   5 where could I find history of projects configuration? 

    Thanks again!

Best Regards,
Jane 


permanent link
Ralph Schoon (59.7k23643) | answered Mar 04 '16, 5:03 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Jane,

it sounds - and I don't know how the system got there -  as if there is a problem with the workflow "Defect workflow".

Here a part of the specification:

startActionId="com.ibm.team.workitem.defectWorkflow.action.confirm"> Something is wrong with the Initialize action.



It might be better to involve support. Not sure.

Comments
Matt Muller commented Mar 04 '16, 5:33 a.m.

Jane,

I agree with Ralph,  prob. best if you are new to RTC to get support involved.


jane zhou commented Mar 04 '16, 6:04 a.m.

   Hi Ralph,


       Thanks for your suggestion, it can work now!
       But options for Start Action are  "None/ Start Analysis/ Start Implementation / Start Code review/ Resolve/ Close"
        No "initialize" there,  So I configured as "Start Analysis", and it can work.
        I suppose the difference for Start Action is impacted by process template used? maybe because I use Scrum as template, and you use Formal software development process as template?

        Thanks!

Best Regards,
Jane


Nate Decker commented Mar 04 '16, 1:23 p.m.

Jane,

Ralph's screenshot is just notional as a sample configuration. Your own configuration may very well be different. The "Start Action" just defines which action is used when creating the work item. So you'll have to pick from among the actions defined in your own workflow. It might not be called "Initialize". In our environment, we usually use "Create" and in at least one case we use "Open". Just use whatever action makes the most sense for your own workflow.

Your answer


Register or to post your answer.