It's all about the answers!

Ask a question

SCM Accept Issue with RTC 5.0.2

Steven Drogoszewski (524) | asked Feb 04 '16, 10:41 a.m.
We have upgraded RTC client on AIX to version 5.0.2. My build process fails when accepting change sets into workspace. The exit code is 52 "Indicates that an accept succeeded, but there were no incoming changes, so the workspace remains unchanged."  I'm assuming exit code 52 should not indicate failure. Did not have this issue on previous version of RTC. Is this a bug in ver 5.0.2? 

This is where failure occurs:
        <exec executable="${rtc.scm}" failonerror="true">
            <arg value="accept"/>
            <arg value="-r"/>
            <arg value="${rtc.login.alias}"/>
            <arg value="-s" />
            <arg value="${}" />
            <arg value="-t" />
            <arg value="${}" />
Steve D.

Shashikant Padur commented Feb 04 '16, 10:38 p.m.

As you rightly mentioned, 52 return code has a special meaning to indicate there wasn't any changes to accept and the command succeeded. I believe it was introduced in 502.

Accepted answer

permanent link
Geoffrey Clemm (30.1k33035) | answered Feb 04 '16, 7:34 p.m.
That sounds like an error to me ... I'd suggest submitting a defect to IBM Support.
If a command succeeds, it should return 0 exit code, and the behavior should not change release to release.

Steven Drogoszewski selected this answer as the correct answer

Steven Drogoszewski commented Feb 18 '16, 7:43 a.m.

FYI, we have installed version 6, it has same issue.

Geoffrey Clemm commented Feb 19 '16, 1:58 a.m.

Yes, until that 5.0.2 change is explicitly backed out or fixed, you will continue to see this behavior.

One other answer

permanent link
Steven Drogoszewski (524) | answered Feb 22 '16, 11:39 a.m.
I did open a defect with Rational Team, here is their response:

"the old behavior can be enabled by setting the VM property "" to true. For instance, you can add the following line to the VM args section of the scm.ini file:"

We are running in AIX so there is no scm.ini. I added the property to and the error no longer occurs.

Your answer

Register or to post your answer.