It's all about the answers!

Ask a question

How to upload files with size greater than 100MB RTC without changing default clm admin settings


Venkatesh Prasad (2117) | asked Jan 29 '16, 5:08 a.m.
Hi,

Could any of you help me with a solution to the below problem we have please.

We need to know how to upload files with size greater than 100MB in RTC without changing any default clm admin settings

We do not wish to make any changes in the settings because its a shared server and there are many projects using the server and its just one project that is complaining this. We therefore will be interested in a workaround rather than making any changes from the server side.

Thanks
Venkatesh Prasad

Comments
Venkatesh Prasad commented Jan 29 '16, 6:36 a.m.

Thanks Arun,

Basically we are looking at uploading the file by de-fragmenting it or any other workarounds that are available.
Does RTC support any such third party de-fragmenting tools for uploading big files ?
OR
Are there any other solutions ?

Zipping has not helped as its still not within the specified file limit.

Thanks
Venkatesh Prasad


Geoffrey Clemm commented Jan 29 '16, 5:23 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Just for interest's sake, what kind of file is this?   Normally, one does not store 100MB files in RTC, except under special circumstances.


Venkatesh Prasad commented Jan 29 '16, 9:33 p.m. | edited Jan 31 '16, 6:33 p.m.

 Hello Geoffrey,


Thanks for the reply.
Our customer said that they have Word document which contained several embedded PowerPoint presentations, and therefore they took out the PowerPoint presentations and uploaded each file separately.

2 answers



permanent link
Arun K Sriramaiah (3.2k12252) | answered Jan 29 '16, 6:22 a.m.
Hi Venkatesh.

I don't think it is possible to do that, since the property should be enabled in server.

Regards,
Arun.

permanent link
sam detweiler (12.5k6184201) | answered Jan 29 '16, 7:55 a.m.
edited Jan 29 '16, 8:36 a.m.
You cannot get around the limit..  if you need to upload more data, then all you can do is create multiple attachments, each with some part of the data, then the user must combine again.

in one of my prototypes for a prior company, I modified the product code to support links to files in a shared file system as the attachment, rather than holding the file itself. so the file size limit would not have been an issue. I set a second limit in config (CCM Web system Admin console same place normal size is configured) on automatically using links if over 1 meg,  We had files files in the many gigabyte size, that I didn't want stored in the database to begin with. also we had an obligation to document that we destroyed the data no longer than 90 days after closing the ticket. (customer support).  and this was prior to attachment delete support

due to browser anti-hacking security, file uploads don't come in with the ACTUAL filename, but a fake one, so I couldn't tell if the file was on the shared filesystem.. that made the darned thing not work completely.
as the RTC product is going to more and more browser based function, this limitation was seen as a real usability problem.  I no longer work for the prior company

I had opened enhancement request https://jazz.net/jazz/web/projects/Rational%20Team%20Concert#action=com.ibm.team.workitem.viewWorkItem&id=153049
wow, almost 5 yrs ago now.. last update almost 2 yrs ago


Comments
Venkatesh Prasad commented Jan 29 '16, 9:01 a.m.

Thanks for the reply Sam.

Unfortunately, there are no changes that we can do on the server side as its a shared server and  affects all other projects on the server.

So, may be, as you said, the only available option is to break up the file into pieces and upload it (if that is possible). Fortunately, our customer had Word document which contained several embedded PowerPoint presentation, and therefore they took out the PowerPoint presentations and uploaded each file separately.

But, this may not be the same in other cases. So, I hope Rational comes up with a workaround or a permanent solution to this.

Thanks
Venkatesh Prasad

Your answer


Register or to post your answer.