It's all about the answers!

Ask a question

Issue after repoininting project area to different process configuration

Rashmi B (19126) | asked Jan 27 '16, 7:49 p.m.

I have a project area A created with project configuration PM1 and now I created a new Project configuration PM2 with additional attributes.
I re-pointed the A to PM2, however new attributes are not showing.
I also tried creating new Project area B pointing to PM2. This works fine.
What are the steps I need to take to apply the new re-pointed project configuration changes to Project Area A?

I am using RTC 5.0.2

Accepted answer

permanent link
Marek Siekierski (817510) | answered Jan 27 '16, 8:14 p.m.
edited Jan 27 '16, 8:42 p.m.
Hi Rashimi,

If the process contain new attribute definitions for your work item types, old work items will not contain those fields unless you perform a work item sync. Can you try to run a query to list all the work items in Project Area A that you with to update with your new attributes > select all > right-click the work item icon and select the option synchronize attributes? Does this resolve your issue?
Rashmi B selected this answer as the correct answer

Rashmi B commented Jan 28 '16, 8:40 a.m.

Thanks for the response.

I am able to see synchronize attributes option in the RTC client, however after clicking on sync am not seeing new attributes loaded in the work items.
Is there any additional step I need to take to make this work?
I don't see any error either.

Rashmi B commented Jan 28 '16, 8:53 a.m. | edited Jan 28 '16, 9:44 a.m.

It worked, thank you

One other answer

permanent link
Donald Nong (14.5k314) | answered Jan 27 '16, 8:42 p.m.
I'm more concerned about the existing attributes of the existing work items when you made the switch - make sure you can see the states, enumerations and etc OK before proceeding any further.

Is PMR2 based on PM1? You should be safe if the answer is yes. Otherwise you can get into deep trouble. Remember for the states, enumerations and etc, the "Id" rather than the "label" (what you see in the UI) is recorded in the work items. If the new process configuration (as in PM2) does not have the exact same Id, there is no way to display the "label" correctly.

For new attributes, the easiest way to check is try to create a new work item. For existing/old work items to get the new attributes, you need to do work item synchronization as Marek suggested.

Rashmi B commented Jan 28 '16, 8:57 a.m.

 Yes I am using PM2 based on PM1.

however I am not seeing the new attributes when I am trying to create new work item

Your answer

Register or to post your answer.