It's all about the answers!

Ask a question

Transferring Data from RTC[5.0.2] to DOORS[9.6] via OSLC through Follow-up Operation


Abhishek Kumar (49112) | asked Dec 04 '15, 2:42 a.m.
edited Dec 04 '15, 2:43 a.m.
Hello Everyone,

We have a requirement to transfer data from a few attributes in RTC to a module in DOORS. A class(say adapter) using eclipse lyo packages was built to transfer the required data to the DOORS system. Then we have created a follow-up operation that will extract the data from the attributes of the work item (for ex: summary,planned for etc..) on the work item save operation and pass theese values to the adapter. 

The lyo component was able to transfer the data to the DOORS module successfully when tested through a sample application in eclipse. but when when included in the follow-up operation this component is not working with the following stack trace: 

Enter this URL in a browser and run again: http://doorsserver:8080/dwa/oauth
-authorize-token?oauth_token=18689471-45b3-4427-9617-840165510a0c
oath exception caught
org.apache.http.conn.HttpHostConnectException: Connection to https://doorsserver:8443 refused
        at org.apache.http.impl.conn.DefaultClientConnectionOperator.openConnect
ion(DefaultClientConnectionOperator.java:158)
        at org.apache.http.impl.conn.AbstractPoolEntry.open(AbstractPoolEntry.ja
va:149)
        at org.apache.http.impl.conn.AbstractPooledConnAdapter.open(AbstractPool
edConnAdapter.java:121)
        at org.apache.http.impl.client.DefaultRequestDirector.tryConnect(Default
RequestDirector.java:562)
        at org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultReq
uestDirector.java:415)
        at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpCl
ient.java:820)
        at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpCl
ient.java:754)
        at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpCl
ient.java:732)
        at com.daimler.stan.doorsclient.CrAdapter.validateTokens(CrAdapter.java:
319)
        at com.daimler.stan.doorsclient.CrAdapter.transferDatatoCr(CrAdapter.jav
a:128)
        at com.daimler.stan.changerequest.CrDoorsAdapter.run(CrDoorsAdapter.java
:127)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
java:60)

On going through the stacktrace it is observed that the port is beeing changed in the redirect url but that was not the case when i was running the program through eclipse..

Can anyone help me out with this!!

Thanks in advance..

Accepted answer


permanent link
Maeve OReilly (3813) | answered Dec 04 '15, 3:26 a.m.
Hi Abhishek

check your dwaHost and dwaProtocol values in DOORS - both are inconsistent above.  The easiest way is to bring up your rootservices  https://doorsserver:8443/dwa/public/rootservices and make sure they are consistent.  The rootservices is generated by the dwaHost, dwaProtocol, dwaHost.  The address you use for DOORS in your RTC Friends Outbound MUST be consistent with what you have actually configured in DOORS or oAuth gives problems.   One of them is wrong. 

If you need to change them in DOORS, run 'dbadmin -dwaPort xxx -data xx@xx' and make sure you get a return message saying it has set it.  Then restart the interop processes. 

If you have to change it in RTC, just add a new Friend outbound with the correct location for DWA rootservices.  Because it does work independent of RTC, I'm inclined to suspect this is the issue but I can't be sure. 

HTH
Maeve
Abhishek Kumar selected this answer as the correct answer

Comments
Abhishek Kumar commented Dec 07 '15, 3:25 a.m.

 Hi Maeve,


Thanks a lot it worked changing the dwa port in the doors system solved the issue.

Thanks,
Abhishek

One other answer



permanent link
Abhishek Kumar (49112) | answered Dec 09 '15, 2:40 a.m.
 Hi Maeve,

While making a POST call to the DOORS server i encounter the following error thrown on the line:

clientResponse creationResponse = client.createResource(
                            requirementFactory, requirement,
                            OslcMediaType.APPLICATION_RDF_XML,
                            OslcMediaType.APPLICATION_RDF_XML);

Following is the stack trace: 

org.apache.wink.client.ClientRuntimeException: java.lang.RuntimeException: java.lang.RuntimeException: javax.ws.rs.WebApplicationException: java.lang.ClassCastException: org.apache.xalan.processor.TransformerFactoryImpl incompatible with javax.xml.transform.TransformerFactory
at org.apache.wink.client.internal.ResourceImpl.invoke(ResourceImpl.java:240)
at org.apache.wink.client.internal.ResourceImpl.invoke(ResourceImpl.java:189)
at org.apache.wink.client.internal.ResourceImpl.invokeNoException(ResourceImpl.java:181)
at org.apache.wink.client.internal.ResourceImpl.post(ResourceImpl.java:322)
at org.eclipse.lyo.client.oslc.OslcOAuthClient.createResource(OslcOAuthClient.java:186)
at com.daimler.stan.doorsclient.CrAdapter.transferDatatoCr(CrAdapter.java:204)
at com.daimler.stan.changerequest.CrDoorsAdapter.run(CrDoorsAdapter.java:129)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

Any idea how to handle this exception??

Thanks, 
Abhishek..

Comments
Maeve OReilly commented Dec 09 '15, 5:51 a.m.

https://jazz.net/forum/questions/212633/error-in-making-a-post-call-to-doors96-via-rtc502-follow-up-operation?page=1&focusedAnswerId=212656#212656

Your answer


Register or to post your answer.