It's all about the answers!

Ask a question

Initialize project area failed in RTC


Vidya Jothiraman (3513) | asked Nov 03 '15, 6:24 a.m.
edited Nov 03 '15, 9:36 a.m. by Ralph Schoon (63.2k33646)
Hi

Felt sharing this learning would benefit others here in this forum.

Recently I extracted process template from a sandbox server , imported in production and created a project area out of it. Though the project area got created, it stopped with this message "Initialize project area failed"

With support from Rational team found that , this was because if any custom attribute is made as mandatory field, the initialization will not work. Hence made that attribute as non-mandatory, extracted process template and re-imported the project area. It worked :-)

After importing , made that attribute as mandatory. But again got the message "Generate Team Invitation failed" while sending team invitation. Made that attribute as non-mandatory, the error went off.

So is there no way a custom attribute can be made mandatory?


One answer



permanent link
Raj K (10222125) | answered Nov 03 '15, 7:27 a.m.
Hi Vidya,
   It is because the "Task" that are automatically created during project creation & adding team members cannot pre-populate the field on creation. There are a fewchoices.

1) Make a field mandatory after creation
2) Remove the automatic task creation from the template/project.
3) Create a new workitem type and use that.
4) Make the field mandatory only for specific roles at "new" state.

Thanks
Raj

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.