It's all about the answers!

Ask a question

Client compatibility with different server versions


Michael Johnson (4413) | asked Nov 02 '15, 1:52 p.m.
retagged Feb 24 '17, 5:00 p.m. by Ken Tessier (84117)

To support a JRS and DCC 6.0 installation I was told that only my JTS server needs to be at version 6.0.  Everything else is at 5.0.2 (RM, QM, CCM). 

I am installing a 6.0 license file on to the license server. 

My question is will end-users still on the RTC 4.0.6 client have a version compatibility problem. 

As I see it, the CCM server is still v5.0.2 and this will not violate the (n - 1) version compatibility - or will it because the JTS server (which governs logins) will be at 6.0?

The reason for this partial upgrade is to get a team going with some enhanced metrics reporting, but to upgrade (in our environment) takes a bit of planning and time.

Accepted answer


permanent link
Ken Tessier (84117) | answered Feb 24 '17, 5:00 p.m.

For reference, see Client and server version compatibility


Ken 

Michael Johnson selected this answer as the correct answer

One other answer



permanent link
Ralph Schoon (57.1k23642) | answered Nov 03 '15, 3:24 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Michael,

this is a quite interesting scenario. As far as I can tell, the RTC clients connects to the CCM server and not the JTS. Look at the repository connection that has the ccm context root. So from that I would expect that the clients can still connect. I have not tried this however.

Although n-1 compatibility is supported if at all possible, it has always been stated that you should use the latest client if at all possible. You will for example not get new capabilities with the old client.

What is the reason to stay on 4.0.6 clients while working against 5.0.2 in the first place? 

Comments
Michael Johnson commented Feb 10 '17, 8:20 a.m.

We are still trying to come up with an upgrade strategy. 

We have hundreds of users and cannot afford much down time at all. 

Does the n-1 compatibility pertain only to major versions? 

Meaning v5.0.x client works fine for any 6.0.x server. 

My apprehension comes from the minor versions.  We have (2) 5.0.2 CCM servers.  We need to upgrade, but only (1) of them can be upgraded for the time being.  Most users have a 5.0.2 client.  If we upgrade to 6.0.3.....are we still in "compliance."

I truly appreciate your time and help with this.

Michael


David Lafreniere commented Feb 21 '17, 12:00 a.m.
FORUM MODERATOR / JAZZ DEVELOPER

Yes, a 5.0.2 client should work with a 6.0.3 server. The 'n-1' is referring to the major versions.


Michael Johnson commented Feb 21 '17, 7:43 a.m.

Thank you, David!  That makes my life so much simpler!

Your answer


Register or to post your answer.