It's all about the answers!

Ask a question

Error when importing ClearCase history into RTC


David Maza (134) | asked Oct 28 '15, 4:51 a.m.
edited Oct 28 '15, 6:23 a.m.
 Hello,

I'm trying to import ClearCase version history into RTC 4.0.4 via the Eclipse client but when I do so I get the below error message:

The error below was detected while initializing the Connector algorithm.  The Connector must be properly initialized to function, so further processing is impossible.  Please fix the problem and retry the operation.
CRRTC4061E: The synchronization process cannot be completed. The "cleartool" command completed with a non-zero status or error message:
 
cleartool describe -fmt %[components]CXp stream:B_Project_Integration@vobuuid:c6454e2c.029b40bc.925f.da:a3:0f:8a:cc:fb
component:B_nr@\projects, component:B@\projects, component:C@\projects
cleartool: Error: Unable to determine absolute pathname for "c6454e2c.029b40bc.925f.da:a3:0f:8a:cc:fb" - No such file or directory 


When I run this command inside a ClearCase view that has already been configured, it returns a normal result: 

C:\project>cleartool describe -fmt %[components]CXp stream:B_Project_Integration@vobuuid: 
c6454e2c.029b40bc.925f.da:a3:0f:8a:cc:fb 
component:B_nr@\projects, component:B@\projects, component:C@\projects 


When I run it outside of the ClearCase view, I get this error:

C:\>cleartool describe -fmt %[components]CXp stream:B_Project_Integration@vobuuid:c6454 
e2c.029b40bc.925f.da:a3:0f:8a:cc:fb 
cleartool: Error: Unable to determine absolute pathname for "c6454e2c.029b40bc.925f.da:a3:0f:8a:cc:f 
b" - No such file or directory 
component:B_nr@\projects, component:B@\projects, component:C@\projects 


Is there anyway to point the the importer tool to a pre-existing view so the command will work? I tried changing the UNC path in the Eclipse wizard to a pre-existing view but I still get the same error

Accepted answer


permanent link
Geoffrey Clemm (29.9k23035) | answered Oct 28 '15, 9:24 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
This problem has been reported (for example, Import from Clearcase : Unable to determine absolute pathname for vob uuid (269416) ), but the development team was not able to reproduce it.

From one of the comments in the work item:
I have found a work around that works, I start the RTC client from inside my dynamic view and also make sure my RTC client workspace directory is inside my dynamic view. I believe this forces the current working directory to be inside a view in the RTC client and means I avoid the cleartool error when the clearcase import runs.

If that workaround doesn't work for you, working with your local clearcase admin to figure out why you are getting that error when you invoke that command outside of a view would be very helpful.   Clearly, there should be no need to be inside of a view for that command to execute successfully (since it is a vob uuid).
David Maza selected this answer as the correct answer

One other answer



permanent link
Tamir Gefen (7837) | answered Oct 28 '15, 5:58 a.m.
edited Oct 29 '15, 2:37 a.m.
You should find out how to provide the PVOB tag name instead of "vobuuid:c6454e2c.029b40bc.925f.da:a3:0f:8a:cc:fb"

Regards,
Tamir Gefen, ALMtoolbox

Comments
David Maza commented Oct 28 '15, 6:54 a.m.

 In the ClearCase stream selector field, I specified "B_Project_Integration@\projects". I just tried "B_Projects_Integration@\vobuuid:c6454e2c.029b40bc.925f.da:a3:0f:8a:cc:fb" but that didn't work either. 

Your answer


Register or to post your answer.