It's all about the answers!

Ask a question

weblogic support for WTP tools plugin


Alexander Schinko (3551812) | asked Jul 24 '09, 12:30 p.m.
Hello,

I succfully installed WTP und the Oracle Enterprise Pack for Eclipse (OEPE) on RTC2.0. But I still missing the Weblogic Server in the Server list.

First I installed WTP 2.0 (http://archive.eclipse.org/webtools/downloads/drops/R2.0/R-2.0-200706260303/) and OEPE 1.0 (http://www.oracle.com/technology/software/products/oepe/oepe_1.html). When I restarted eclipse and tried to add weblogic server, I have only http and j2ee preview). I can't download WebLogic as a new server adapter.

Then I tried to install WTP 3 and OEPE 1.1.1.1. With that I have Oracle Application Server 10 in the list, but not Weblogic 9.x. Then I downloaded Oracle Weblogic Server Support (from additional addapters list), but its still missing in the list of servers.
I've seen that Eclipse is putting those weblogic files into eclipse/jazz/foundation. So I moved them to eclipse/, but its still not working.

Any ideas? For me it seems that either Oracle or IBM tries to block Weblogic from using.

Thanks for help!

2 answers



permanent link
Jose Miguel Ordax Cassa (2.4k2126100) | answered Jul 25 '09, 3:47 a.m.
schinal wrote:
Hello,

I succfully installed WTP und the Oracle Enterprise Pack for Eclipse
(OEPE) on RTC2.0. But I still missing the Weblogic Server in the
Server list.

First I installed WTP 2.0
(http://archive.eclipse.org/webtools/downloads/drops/R2.0/R-2.0-200706260303/)
and OEPE 1.0
(http://www.oracle.com/technology/software/products/oepe/oepe_1.html).
When I restarted eclipse and tried to add weblogic server, I have only
http and j2ee preview). I can't download WebLogic as a new server
adapter.

Then I tried to install WTP 3 and OEPE 1.1.1.1. With that I have
Oracle Application Server 10 in the list, but not Weblogic 9.x. Then
I downloaded Oracle Weblogic Server Support (from additional
addapters list), but its still missing in the list of servers.
I've seen that Eclipse is putting those weblogic files into
eclipse/jazz/foundation. So I moved them to eclipse/, but its still
not working.

Any ideas? For me it seems that either Oracle or IBM tries to block
Weblogic from using.

Thanks for help!

RTC 2.0 is based on Eclipse 3.4.2 so you should install WTP 3.0.5 and
not 2.0

Then, try to add as Update Site:
http://download.oracle.com/otn_software/oepe/ganymede/wls-adapter/ and
install from there although via WTP Server Adapters should work.

Restart Eclipse after your installation to make sure everything is cleaned.

Also, try to ask at WTP and Oracle forums because theoretically RTC
shouldn't affect to WTP or Oracle stuff.

Hope this helps,

Chemi.

permanent link
Alexander Schinko (3551812) | answered Jul 27 '09, 1:06 p.m.
Hello Chemi,

thanks a lot for the answer. Unfortunatly it doesn't work for me, also with WTP 3.0.5. I can install the OEPE module, but only partly.
The Oracle Weblogic Server Tools feature is still missing even when the files are in the directory, only the Oracle Web Tier Tools feature and the Oracle Enterprise Pack feature is currently installed.

I dont know further. I nearly installed all the features from the Oracle Enterprise Pack all-in-one distribution into RTC, but I can't make the Weblogic feature running.

We are still testing RTC for use and WebLogic is crucial for our migration.

Your answer


Register or to post your answer.