It's all about the answers!

Ask a question

After Upgrade from 5.0.1 to 6.0, RQM has execution record errors.


Fabian Briseño (9410) | asked Sep 30 '15, 8:27 p.m.
Hello Everyone.
We performed a CLM Upgrade from CLM version 5.0.1 to 6.0, almost all went smooth but after CLM upgrade we have encountered problems with RQM execution records. Some of them are blank and don't load at all, other give us Item "Handle must not be null" error.

Has anyone experienced this issue before.

Any help you could provide would be helpful.

Environment runs on Linux, have tryed with other web browser and same result.

Regards.






Accepted answer


permanent link
Brett Bohnn (94111155) | answered Oct 01 '15, 3:40 p.m.
Hi,

The problem is defect work item https://jazz.net/jazz02/resource/itemName/com.ibm.team.workitem.WorkItem/142488 "TCER job cannot be deleted after migration to 6.0 - Item Handle Must Not be Null Error" but there are possibly other symptoms of having execution jobs from 5.0.x in the execution console when upgrading to 6.0 (described in the defect Don references). Work on this defect (WI 142488) is in-progress.

The defect Don refers to https://jazz.net/jazz02/resource/itemName/com.ibm.team.workitem.WorkItem/141926 fixes the problem of being unable to schedule new executions in 6.0 when jobs from 5.0.x cannot be cancelled. It does not fix the error cancelling jobs created before the upgrade. WI 141926 defect has been delivered to 6.0 iFix004 which should be available some time the week of October 12.

Have you tried to schedule new jobs or run existing scheduled jobs? They may not run
.

As Don noted, you should also check the qm.log to see if there is a repeated exception like the following:

2015-09-11 18:09:29,546 [qm: AsynchronousTaskRunner-1 @@ 18:09] ERROR com.ibm.rqm.execution                               - Exception occurred while executing Sequence sched3's step 1
com.ibm.team.repository.common.transport.internal.registry.ServiceNotFoundException: The service 'com.ibm.rqm.execution.service.internal.rest.ExecutionTaskRestService@3a673a67' failed to find the required service 'interface com.ibm.rqm.configmanagement.service.IQualityManagerConfigurationService'.  Check <prerequisites> in plugin.xml.
at com.ibm.team.repository.service.AbstractService.getService(AbstractService.java:788)


That is another possible symptom that is also fixed through WI 141926 (iFix006 of 6.0)

Thanks,
Brett


Fabian Briseño selected this answer as the correct answer

One other answer



permanent link
Don Yang (7.7k21110139) | answered Sep 30 '15, 9:47 p.m.
Hi, Fabian

The symptom seems to be similar to the known defect here:

https://jazz.net/jazz02/web/projects/Rational%20Quality%20Manager#action=com.ibm.team.workitem.viewWorkItem&id=141926

In the known defect, the qm.log will show something like:
=====
[http-bio-9443-exec-46 @@ 22:30 clmuser 
<RQMConnectionHelper/v0.1@127.0.0.1> 
/qm/service/com.ibm.rqm.integration.service.IIntegrationService/
resources/JKE+Banking+%28Quality+Management%29/tasks/urn:com.ibm
.rqm:tasks:54]  WARN com.ibm.rqm.integration.service 
- IntegrationService:perform_PUT AQXIN2508W HTTP request PUT 
https://myrqmserver.ibm.com:9443/qm/service/com.ibm.rqm.integrat
ion.service.IIntegrationService/resources/JKE+Banking+%28Quality
+Management%29/tasks/urn:com.ibm.rqm:tasks:54 returned HTTP 
error status code 500. 
com.ibm.team.repository.common.TeamRepositoryException: Item 
Handle must not be null 
at 
com.ibm.team.repository.service.AbstractService.runWithActiveCon
figuration(AbstractService.java:1064) 
===========
You may want to check with the log first. More importantly, I would suggest to
contact the support team to confirm if the root cause is the same or different
one.



Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.