It's all about the answers!

Ask a question

Attach a file to an existing work item


Pooja Biwalkar (481024) | asked Jul 06 '15, 3:37 p.m.
 Hi,

I have a bunch of already existing  work items in the past.I am trying to attach files to these wok items from the attachments/links section.But its giving me an error saying 'Save work item failed'.I amn't able to attach files JUST for the already existing ones;for the new work items it works fine.

What can be a solution to this problem?  

Comments
Taki Nakajo commented Jul 06 '15, 10:33 p.m.

Can you tell us more information in order to investigate?

  1. RTC version?
  2. How many project area are affected?
  3. How many project area do you have?
  4. Is this a production project or a test project?
  5. How many existing work items are affected? or confirmed?
  6. Does this happen on a Web client or on a Eclipse client?
  7. What do you see in the JazzTeamServer/server/logs/ccm.log when you have the error?


Pooja Biwalkar commented Jul 07 '15, 4:44 p.m.

 Sure.


Using 5.0.2 
One Project area
We have more than 10 project areas
It is a Production project
Say about 50 work items
Web client.Haven't tried it using Eclipse client
Haven't checked Jazz team server logs



Taki Nakajo commented Jul 07 '15, 8:59 p.m.

Hi, Pooja,


I understand you have the issue in the only 1 project area among 10+ PAs.

It would be better if you can capture error messages in the JazzTeamServer/server/logs/ccm.log when you reproduce the issue?

or investigate further like..
1.  Is it a specific work item type?
2.  Is the file size is less 10MB, 50MB, more than 50MB?
3.  What is the last work item that a user could attach a file?

One answer



permanent link
sam detweiler (12.4k6180201) | answered Jul 06 '15, 4:00 p.m.
saw a problem similar to this last year.

doing it from the web?   is the workitem 'category' a child category? what RTC version?

two workarounds..

1. use the eclipse UI
2. temporarily change the category to a root category, then save the workitem with the attachment,
   then change the category back, and save again

see https://jazz.net/jazz/web/projects/Jazz%20Collaborative%20ALM#action=com.ibm.team.workitem.viewWorkItem&id=313008

Comments
Pooja Biwalkar commented Jul 07 '15, 2:53 p.m.

hi Sam,


I am doing this using the web.Most of our customers use the web over the client so web is what we want to use always.It's the 5.0.2 version of RTC. No the work item category is not a child category.

We tried changing the category to a root category and then saving the workitem but it still doesn't work. 

Is this still an existing defect for IBM? 


sam detweiler commented Jul 07 '15, 2:56 p.m.

I don't know if its still a defect, I ama customer too.  I was working on 4.0.4 at the time and t said it was fixed on 4.0.2.. but clearly not for that installation.

I have not been there in a year now, so I don't know if they received a fix



Pooja Biwalkar commented Jul 08 '15, 10:00 a.m.

 Oh ok..sure thanks for the reply Sam. 

Your answer


Register or to post your answer.