It's all about the answers!

Ask a question

JBE loads everything EXCEPT what I want


Andy Jewell (24225669) | asked Jul 02 '15, 7:12 p.m.
edited Jul 02 '15, 7:14 p.m.
I have been using Jenkins but thought I'd give JBE a try but I'm running into a funny problem right off the bat.

My build workspace only has ONE component out of a dozen loaded because I'm only interested in that component.  But when the build runs, somehow it loads ALL the components.  But here's the funny part -- it excludes the ONE component that I DO want loaded!

Ok, that's funny but to be fair initially I put this one component in the box "Components to Exclude" because I mistakenly was thinking that was "Components to Include".  But I subsequently CLEARED that box and still get this behavior.

When I started getting this behavior I thought I'd go back to that box and EXCLUDE all those other components but that is the one spot that it seems to be reading my build workspace because only ONE component is listed in the "Components to Exclude" dialog box.

Can someone please advise on how I can straighten this out?  In summary:

I have a stream with a dozen components and a workspace from that stream that has only one component.  I only want to load or build that one component but ironically, cannot get it loaded into the build workspace.

Now if I had to, I wouldn't care if everything was loaded but the real problem is that it's not loading the one component I need.

Comments

Andy Jewell commented Jul 05 '15, 11:28 p.m.

It's not exactly my situation, but indeed I think the behavior is similar.  I will recreate everything from scratch and see if I can refine it to the issue these are identifying.  Thanks for pointing these out.

One answer



permanent link
Andy Jewell (24225669) | answered Jul 06 '15, 12:03 p.m.
This was a bit of user error.  The component in question was not owned by the team, it was a private component.  Once that was resolved, it was loaded.  Still not sure why all the components of the stream were loaded since the workspace only contained one component, but it's fine for now, just a little sloppier than I'd prefer.

Your answer


Register or to post your answer.