It's all about the answers!

Ask a question

SCM with --json (BuildToolKit 5.0.2 and RTC Server 5.0.2 iFix 005) Hangs

Oliver Vinn (261) | asked Jun 18 '15, 8:57 a.m.
If the scm is invoked with --json the command never returns. 
If i run same command but without --json it returns with expected result.


scm status [OK]
scm status --json [HANGS]

I've tried recreating sandbox, deleting scm cache (where aliases, repositories etc.. stored) and still it fails!

One answer

permanent link
Shashikant Padur (4.2k27) | answered Jun 18 '15, 11:20 p.m.
Is the command run via a script? or at the command prompt? I do not know if it would make a difference but could you try using the cli from SCM package instead of the BuildToolkit?
Either way, you need to raise a ticket to investigate this issue.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.