It's all about the answers!

Ask a question

Problem in deploying server side plugin in RTC 5.0.2

Parveen Patel (77122) | asked Jun 02 '15, 8:41 a.m.
I have created one server side participant in RTC  for Work item save operation.
I have followed all the steps to deploy plugin but I can not find any entries in operation participant.
Is there any problem with deploying plugins in RTC 5.0.2?
Also I am getting error in error tab i.e. bundle not found.

Please,give any suggestions.

Thanks in advance.

2 answers

permanent link
Ralph Schoon (62.0k33643) | answered Jun 02 '15, 8:57 a.m.
edited Jun 02 '15, 8:57 a.m.
No, there is no problem in deploying them in 5.0.2. If you have bundle not found messages you got the plugin/feature/update site wrong. You are missing these dependencies and hence the plugin is not loaded.

Check the dependencies, remove the stuff you don't need and make sure what you have is in the common RTC API, since you need to deploy the providers at the server as well as in the eclipse client.

Look at for an example.

Parveen Patel commented Jun 03 '15, 1:00 a.m.

 Hi Ralph,

In my ccm log files I am getting this error:
CRJZS0383E The "my-plugin" bundle could not be resolved.
2015-06-02 15:02:01,155 [       Launch callback handler] ERROR eam.repository.provision.internal.ProvisionService  - CRJAZ0291E The following bundle could not be started: The server might need to be reprovisioned or reinstalled.

org.osgi.framework.BundleException: State change in progress for bundle "file:/D%3a/IBM/JAZZTE~1/server/conf/ccm/sites/update-site/plugins/" by thread "Start Level Event Dispatcher".

Please,provide any guidance on this.


Ralph Schoon commented Jun 03 '15, 4:23 a.m. | edited Jun 03 '15, 4:27 a.m.

Did this work on Jetty? If not, try to fix this on Jetty.

I can not remote debug your deployment problem. I can only hint you to study the structure and the data from the Rational Team Concert Extensions Workshop to try to understand how the declarative parts of the update site, feature and plugin belong together. I tried to also show some best practices for that in

In your case the server tries to find a bundle named "my-plugin" in the deployed Jar file and that is either not in there or the name/id is different.

Parveen Patel commented Jun 15 '15, 1:03 a.m.

 Hi Ralph,

I have also tried simple check summary advisor plugin which is available on example.Which I have successfully implemented on 5.0 but I am not able to deploy the same plugin in RTC 5.0.2.

permanent link
Parveen Patel (77122) | answered Aug 05 '16, 7:02 a.m.

Hi All,

I have resolved this issue by installing the CLM 5.0.2 using web installer.

I didn't found out the reason, why there is plugin deployed issue when we install it using repository set files.

Your answer

Register or to post your answer.