It's all about the answers!

Ask a question

How to set SCM_ALLOW_INSECURE


shalini saini (161527) | asked Jun 01 '15, 5:18 a.m.
edited Jun 01 '15, 5:23 a.m.
 What are the steps to configure the SCM Source control command line Interface environment variable 'SCM_ALLOW_INSECURE' on a build engine? What is the impact of of setting it to TRUE?


One answer



permanent link
Shashikant Padur (4.2k27) | answered Jun 01 '15, 11:37 p.m.
JAZZ DEVELOPER
When RTC SCM CLI starts it tries to secure the config directory by setting the right permissions on that directory. The config directory is by default the <user home directory>/.jazz-scm or it picks it up from the --config option if specified.

The reason to secure the directory is because the user can inform the cli to cache the credentials during login. If for some reason the cli could not secure the directory it will throw an error. Setting SCM_ALLOW_INSECURE will skip this permission check and continue even if the directory is not secure (i.e., accessible to others in the machine).

Comments
shalini saini commented Jun 02 '15, 12:14 a.m.

 But how do we set the property as TRUE? What is the syntax?


Shashikant Padur commented Jun 02 '15, 1:13 a.m.
JAZZ DEVELOPER

It just checks the existence of the environment variable. You can set it to SCM_ALLOW_INSECURE=1 or SCM_ALLOW_INSECURE=true or for that matter any value.


By the way, this flag does not have any impact on JBE. It is only impacted when you run the scm cli commands.


shalini saini commented Jun 03 '15, 6:11 a.m. | edited Jun 03 '15, 6:18 a.m.

 Again, what is the syntax to set this property? And where do we set it? Do we set it at the configuration directory i.e.‘/direc./<USER HOME DIREC.>/.jazz-scm'



Shashikant Padur commented Jun 03 '15, 6:37 a.m. | edited Jun 03 '15, 6:38 a.m.
JAZZ DEVELOPER
Before you run the commands on the command prompt, in windows 'set SCM_ALLOW_INSECURE=1' or in linux 'export SCM_ALLOW_INSECURE=1'.
You can also set this value by adding the below line to the scm.ini file:
-DSCM_ALLOW_INSECURE=1


shalini saini commented Jun 03 '15, 7:32 a.m.

 Thank you

Your answer


Register or to post your answer.