It's all about the answers!

Ask a question

Jazz Client Libraries compatibility issues


Maria Velasco (4641) | asked Jun 23 '09, 3:34 p.m.
Hello,

We were using the Jazz Client Libraries (1.0.1) with the RTC Server 1.0.1. We change to the Jazz Client Libraries (2.0) to use with RTC Server 2.0. However, now we are wondering if there is one set of Jazz Client Libraries that we can use with both RTC Server 1.0.1 and 2.0? Is it possible to use the Jazz Client Libraries (version 2.0) with both RTC Server version 1.0.1 and 2.0?

Our goal is to be able to support both version (1.0.1 and 2.0) of RTC Server with the Jazz Client Libraries, is there any way to do this currently?

Any help would be greatly appreciated. Thanks in advance!

One answer



permanent link
Jean-Michel Lemieux (2.5k11) | answered Jun 25 '09, 6:07 a.m.
JAZZ DEVELOPER
1.X is not binary compatible with 2.0. You have to use the 1.X libraries against a 1.X server and 2.0 against a 2.0 server.
Cheers,
Jean-Michel

Your answer


Register or to post your answer.