It's all about the answers!

Ask a question

Follow Up action is not called when Project Area uses Process Inheritance


Kevin Eifinger (1211410) | asked Apr 27 '15, 9:04 a.m.
edited Apr 27 '15, 9:09 a.m.
Hi all,
I've written a serverside plugin with a client counter part to configure it.
It is a follow up action and worked perfectly fine during all my tests.

However if I add it to a project area which is using a process from another area, the follow up action is not triggered.
I can configure it normally but the team advisor window in the eclipse client does not show that is was triggered.

This behaviour is only observed when the option "Use a process configuration from another process area..." is chosen.

The plugin works when I select "Do not share the process...."

Does someone have an idea why this is failing with a shared process?
I'm looking for ideas what might cause that the follow-up action is not called.

Comments
Ralph Schoon commented Apr 27 '15, 9:16 a.m. | edited Apr 29 '15, 8:28 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

In which process area do you try to configure the behavior? In the one that shares its process, or in the one that uses it?


Kevin Eifinger commented Apr 27 '15, 10:25 a.m.

In the one that uses it

Accepted answer


permanent link
Kevin Eifinger (1211410) | answered Apr 29 '15, 6:49 a.m.
The Master Project Area had some configurations for the role "Team Member" which did not show up in the Child Project Area.
For everyone with the role "Team Member" this configuration applied due to these changes. The configurations made for "everyone" did not apply anymore.
Adding the plugin/follow up action for the role "Team Member" as well solved the problem.

No error, just RTC functionality.
Ralph Schoon selected this answer as the correct answer

Comments
1
Ralph Schoon commented Apr 29 '15, 6:56 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Thanks for the update. Maybe a RFE is due to make this easier to detect or to make inheritance easier or to be able to have a set of rules that always apply (I submitted this one).


sam detweiler commented Apr 30 '15, 7:35 a.m.

note that you have now broken the sharing inheritance for the child project area.

another debugging thing to note. if the parent project had set 'final' for the inheritance, you could have edited and saved the config on the child, but it would never be used.  turn off final in the parent and suddenly the child changes behavior.

final is configurable for each operation and role in the grid!.. sadly there is no global final setting.


Ralph Schoon commented Apr 30 '15, 7:40 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Sam, please open a RFE or an Enhancement request for this kind of stuff. I thought I had opened one my self but can't find it right now.

Your answer


Register or to post your answer.