It's all about the answers!

Ask a question

RTC 5.0.2 tomcat Service error


Scott Raley (13542731) | asked Apr 02 '15, 9:35 a.m.

Have RTC 5.0.2 installed on SERVER 2012 R2 and running through the instructions to make tomcat a service. The service starts but I can't get to the page. I see in catalina I have an error:

SEVERE: Failed to Initalize End Point Associated With Protocol Handler ["http-bio-9443"]

Throwable occurred: java.io.IOException: ${jazz.connector.algorithm} KeyManagerFactory not available

At org.apache.tomcat.internal.jsse.JSSESocketFactory

anyone know what to try? JRE_HOME and JAZZ_HOME are set as windows environment variables and I have tried setting them on the java tab in the service.


Comments
Lawrence Smith commented Apr 02 '15, 10:23 a.m.
JAZZ DEVELOPER

Is the host uri set properly? It looks like it is looking to connect to a handler at http-bio-9443 instead of https://bio:9443, unless the message is mangling the value.


Scott Raley commented Apr 02 '15, 11:20 a.m.

Where would I check the host uri setting? I don't see this in the java tab and I would suspect it is set correctly since I can run the dos file manually and it runs.


Scott Raley commented Apr 07 '15, 11:41 a.m.

uri is set correctly since I can manually start this. Verified with IBM call

4 answers



permanent link
Erica Tran (1.4k6) | answered Apr 02 '15, 11:34 a.m.
JAZZ DEVELOPER
Hello Scott,

I found another forum post that had the same error you've posted.
Forum Post:  How to fix SEVERE: Failed to initialize end point associated with ProtocolHandler ["http-bio-9443"]
It says the issue was a missing java option.
-Djazz.connector.algorithm=Ibmx509

I hope this helps.

Comments
Scott Raley commented Apr 02 '15, 12:13 p.m.

 Thanks. I will check to make sure I spelled it correctly but that tag is in the java tab.


Scott Raley commented Apr 07 '15, 11:42 a.m.

This is set correctly as I cut and paste these and several other options directly from the server.startup file. IBM is not sure what is going on with this keymanager error. Tomcat does startup as I can get to the page at port 9080 but since it cannot open 9443 I can't get into RTC.


permanent link
Donald Nong (14.4k314) | answered Apr 08 '15, 1:12 a.m.
edited Apr 08 '15, 1:17 a.m.
 If you still see the same error, clearly the Java option "jazz.connector.algorithm" (possibly "jazz.connector.sslProtocol" as well) has not been passed to the Tomcat startup script correctly. One simple way to bypass this is to set the value directly in the Tomcat configuration file - open the file tomcat/conf/server.xml and replace
algorithm="${jazz.connector.algorithm}"
with
algorithm="IbmX509"
and
sslProtocol="${jazz.connector.sslProtocol}"
with
sslProtocol="SSL_TLS"
Report back if the 9443 port still fails to open or you see different errors.

P.S. Make sure you are using IBM Java. Otherwise "ibmX509" will not be available.

Comments
Scott Raley commented Apr 08 '15, 7:56 a.m.

So this does work other than JTS says it can no longer talk to the database (SQL Server). When I check the log file I see that everything starts but a trigger on a stopInternal happens and there a Servlet Destroy msg appears. I haven't seen these before but in the tomcat log I see no errors. I'm using the same sql string that we have in the teamserver.properties file which works manually.


Scott Raley commented Apr 13 '15, 6:54 a.m.

Still unable to talk to SQL Server. IBM thinks I have the path wrong. But what they suggest isn't working for the path.


Donald Nong commented Apr 13 '15, 10:05 p.m.

It may be another case of failing to pass the Java option/parameter to Tomcat. It would be helpful if you can show the configuration GUI of the Tomcat service, so that any potential mistakes can be spotted.


Scott Raley commented Apr 20 '15, 9:50 a.m.

I cannot get a screen shot but manually I have typed below. I am trying not to misspell but because the server is disconnected from the world I have to do it this way. So this starts but still gives the error that the keymanager will no lock 9443

Current Java tags

-DJRE_HOME=file:///c:/rtc/server/jre

-Djava.awt.headless=true

-DSQLSERER_JDBC_DRIVER_FILE=c:\rtc\serer\sqljdbc4.jar

-Djazz.connector.sslProtocol=SSL_TLS

-Djazz.connector.alogorithm=IbmX509

-Xmx4G

-Xms4G

-Xmn512M

-Dlog4j.configuration.file:file:///c:/rtc/server/cof/startup_log4j.properties

-Dcom.ibm.tea.repository.debugMode=true

-Dorg.eclipse.emf.ecore.plugin.EcorePlugin.doNotLoadResourcesPlugin=true

-Dorg.apache.tomcat.util.buf.UDecoder.ALLOW_ENCODED_SLASH=true

-Dorg.apache.cataline.connector.coyoteAdapter.ALLOW_BACKSLASH=true

-Dcom.ibm.teamrepostory.tempDir=
"%TEMP%"


Donald Nong commented Apr 22 '15, 3:31 a.m.

The reason for a screen shot is that we may see any potential mistakes in the configuration. If this is indeed your current setting, then "JAZZ_HOME" is missing. Also, "JRE_HOME" should be set as "-DJRE_HOME=c:/rtc/server/jre", without the "file:///". The SQL Server driver parameter is misspelled "SQLSERER_JDBC_DRIVER_FILE" (probably only when you copied it to this forum, but worth mentioning).

It's better to set the logging level of the Tomcat service to DEBUG (in the "logging" tab) and collect the file commons-daemon.####.


permanent link
Julio A. Velásquez (1215) | answered Jun 15 '15, 5:00 p.m.
Good afternnon, what happened with this issue? We're going to upgrade our CLM 4.0.7 to 5.0.2 and we'd like to know if you resolved this problem...
Thanks!

permanent link
Scott Raley (13542731) | answered Jun 15 '15, 6:13 p.m.
 The answer that fixed the problem - the java batch files were ignoring the windows environment variables so we had to put everything as settings in the batch file (JAZZ_HOME, JRE_HOME, etc).

Your answer


Register or to post your answer.