It's all about the answers!

Ask a question

RQM execution results startTime and endTime is not exported as provided in excel


Don Yang (7.5k2195130) | asked Mar 31 '15, 12:36 a.m.
edited Mar 31 '15, 12:37 a.m.
The user is  testing with RQMExcelImporter v4.0.7(RQM server is 4.0.5) and wants to export execution result startTime and endTime provided in excel as is.  But they always get the result as the one specified in Excel+xxhours
for the local server time. For example, if specifying
Start time:  2014-11-07T11:00:00, the exported result will show Nov 7, 2014, 10:00:00pm(that is UTC+11 for local time zone)
According to the discussions in
https://jazz.net/forum/questions/141469/rqm-execution-results-starttime-and-endtime-is-not-updated-as-provided-in-excel#177136
If Zulu time is not specified(Z removed in the timestamp in Excel), it should not have conversion.
But I tried with v4.0.5 and v5.0.1 (sample: Scripts that create testcases with TCER.cfg/Scripts that create testcases with TCER.xls) and both show the conversion of the time after export to RQM.

Does anyone know how to make the exporter not to convert the specified time in the Excel and export to RQM as is?
Thank you very much.

2 answers



permanent link
Sunil Kumar R (1.1k12743) | answered Mar 31 '15, 4:16 a.m.
JAZZ DEVELOPER
 Hi Dong, yes the time change (excel+/- hours) is expected to occur in a few scenarios. Here is a document where it is explained with examples.


Let me know if any further questions.

Best Regards, Sunil



permanent link
Don Yang (7.5k2195130) | answered Mar 31 '15, 4:54 a.m.
Thanks Sunil for the info.
I am still confusing after reading your blog.
It says:
---
RQM Client and RQM Server in same time zone: If the RQM client (where excel is used) and server are on machines in the same time zone? the TIMESTAMP value specified in the sheet is exported into RQM as is.
-
In my test, I have ExcelImporter 4.0.5 or 5.0.1 which are along with RQM server 4.0.5 and 5.0.1, that is, they are on the same machine.
In excel, I specify the timestamp as 2014-11-07T11:00:00
After exporting to RQM, I notice the execution startTime shows as:
Nov 7, 2014, 10:00:00pm
This is the specified time in Excel+11 hours(as if it is UTC+11 for my local time)
which is not expected. If my understanding is correct, it should export as is which means Nov 7.2014, 11:00:00am in RQM.
Am I misunderstanding anything or use anything wrong? Can you please advise? Thanks

Comments
Don Yang commented Mar 31 '15, 5:42 p.m. | edited Mar 31 '15, 5:43 p.m.

Sunil, I made comments yesterday but not sure if you have seen it so I changed it to an answer so that you can get the message. I am sure you have tested the scenario by removing Z in the timestamp in post: https://jazz.net/forum/questions/141469/rqm-execution-results-starttime-and-endtime-is-not-updated-as-provided-in-excel#177136 and you then create the blog. What version of ExcelImporter did you useĀ  to export so that it will show the timestamp as set in the cfg file(as suggested in the scenario "RQM Client and RQM Server in same time zone:" in your blog? Can you still see the same result when using ExcelImporter 4.0.5 or 5.0.x? Appreciate if you can have a look. thanks

Your answer


Register or to post your answer.