It's all about the answers!

Ask a question

Using process configuration from other project area?

Pravin Patil (104139133) | asked Feb 20 '15, 3:52 p.m.
retagged Mar 02 '15, 5:14 p.m. by Ken Tessier (84117)

I created "ProjectArea-1", + "Allow other projects areas to use the process configuration from this project area".
I created "ProjectArea-2", + "Use the process configuration from another project area for this project area" + used "ProjectArea-1"

When I created a new role "TestRole" in "ProjectArea-1", it did not show up in "ProjectArea-2". 
Even the members from ProjectArea-1 are not showing up in ProjectArea-2.

Pleases suggest.

2 answers

permanent link
Ken Tessier (84117) | answered Mar 02 '15, 5:14 p.m.

The topics in this section of the IBM Knowledge Center might help:  Sharing the process of a project area.  Also, this tutorial:  Standardize process in your organization by using project area process sharing.


permanent link
Geoffrey Clemm (30.1k33035) | answered Feb 21 '15, 3:00 a.m.
Roles are inherited, since they are part of the Process Configuration, but members are not inherited, because members are not part of the Process Configuration.   When you say that TestRole did not show up in ProjectArea-2, where were you looking for it?   Note that you need to refresh your ProjectArea-2 editor view to see the change (and in the case of Eclipse, navigate away from the Process Configuration tab, and then back).

sam detweiler commented Feb 21 '15, 8:28 a.m.

or push the refresh swirl at the top of the process config editor page

Geoffrey Clemm commented Feb 21 '15, 5:30 p.m.

In Eclipse, I believe I had to both refresh and do the navigate back and forth ... but it also might just have been I was being too impatient (:-).

Pravin Patil commented Feb 22 '15, 1:12 a.m.


In eclipse, I tried switching away from Process Configuration view, also tried switching between project areas, also the refresh option, however the changes in Master project area are not showing up in the consuming project area. The changes are not seen in Web too.
I also added a custom attribute to master project area workitem and it did not show up in Consuming project area.

Please suggests.

Geoffrey Clemm commented Feb 22 '15, 2:30 a.m.

To help, we'll need to know where in the consuming project area were you looking?  For roles, you need to look in the list of roles available in Permissions ... the role list in the Role section of the consuming project area process configuration tab is just those added in the consuming project area, and does not show the inherited ones.

Pravin Patil commented Feb 22 '15, 2:48 a.m.


I was checking in the Roles section, however I will check for inherited roles in the roles section of permissions and confirm.
But I also didn't see in Consuming project area's workitem, the new attribute that I added in Defect workitem of master project area.

 Please suggest.

Geoffrey Clemm commented Feb 22 '15, 3:10 a.m.

To see the new attribute in a work item, you need to extend the work item editor(s) to display that custom property (see the on-line help for that, or google for it).   If you have done that, then you should see it in new work items that you create.   To see it in old work items, you should perform the operations described in the forum entries, like

Pravin Patil commented Feb 23 '15, 1:21 a.m.

Thanks, as mentioned by you rightly, I was able to locate the role from master project area in consumable project area, under "Process Configuration > Permissions > Roles".

For getting work item's custom attribute from master project area into consumable project area, I have been googling various sites to get information on "how to extend work item editors", but not getting any clue. Can you suggest on how to do this so that I can get the new attribute added in defect work item from master project area into consumable project area?

sam detweiler commented Feb 23 '15, 7:31 a.m.

He meant, you have to add the attribute to some screen of the workitem.

those screens are called the workitem editor, cause you are editing the values in a workitem. 

RTC doesn't just stick the attribute on some page, YOU have to do the customization work.. 

in the process config, workitems,

and then when you save the editor the config, for workitems being created AFTER you did this, the attribute should show where you configured it to display.

for existing workitems, YOU have to tell RTC to update their state to include the new attribute. As Geoff mentioned

Pravin Patil commented Feb 24 '15, 1:17 a.m.
Thanks. In master project area, I did same as you mentioned:
Under "Project_Configuration > Configuration Data > Work Items > Types and Attributes", I did following configuration:
Workitem type = Defect
Work item editor =
Added a new attribute named "TestInheritance" with type=LargeString

Then in "Project_Configuration > Configuration Data > Work Items > Editor Presentation", I did following configuration:
"Choose the Editor Presentation to edit =",
Under section "Editor Presentation > Overview > Details"
clicked on button "Add Presentation", added "Attribute=TestInheritance", "Kind=Text". Saved the project area.
In consumable project area, created a new DEFECT work item and the attribute "TestInheritance" didnt show up

Am I missing something. Sorry I am not able to attach screenshot here. Please suggest.

Pravin Patil commented Feb 24 '15, 3:33 a.m.

 In master project area, I also created a new workitem following exactly the steps mentioned in

But I don't see this in the consumable project area.

Please suggest on what needs to be done to get this working.

showing 5 of 10 show 5 more comments

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.