It's all about the answers!

Ask a question

Migration from RTC 5.0.1 to 5.0.2. Upgrade script failing with unexpected error


Anbarasu Arivoli (811328) | asked Jan 12 '15, 5:41 a.m.
Dear Experts,
We are trying to upgrade the CLM RTCfrom 5.0.1 to 5.0.2. But while running 
the upgrade script it is failing with unexpected error.                 
                                                                        
Please find the upgrade script ran and the error below,                 
                                                                        
C:\Program Files (x86)\IBM\JazzTeamServer_5.0.2                         
\server>upgrade\jts\jts_upgrade.bat -oldJTSHome "C:\Program             
 Files (x86)\IBM\JazzTeamServer_5.0.1\server\conf" -updateTomcatFiles no
                                                                        
\IBM\JazzTeamServer_5.0.1\server"\repotools-jts.bat -version"' was      
unexpected at this time.                                                
                                                                        
                                                                        
Please help asap.                                                       
                                                                        
Thanks                                                                  
Anbu                        

2 answers



permanent link
Sumant Renukarya (1.1k23339) | answered Jan 12 '15, 5:48 a.m.
edited Jan 12 '15, 5:48 a.m.
Hi Anbu

Please use the following argument along with the rest as above and re-try: 

-oldJTSVersion 5.0.1 





Comments
Anbarasu Arivoli commented Jan 12 '15, 6:04 a.m.

  Hi Sumant.,


I tried what you have suggested, but getting the same error again.
C:\Program Files (x86)\IBM\JazzTeamServer_5.0.2\server>upgrade\jts\jts_upgrade.bat -oldJTSHome "C:\Program
 Files (x86)"\IBM\JazzTeamServer_5.0.1\server\conf -updateTomcatFiles no -oldJTSVersion 5.0.1
\IBM\JazzTeamServer_5.0.1\server"\repotools-jts.bat -version"' was unexpected at this time.

Thanks
Anbu


Anbarasu Arivoli commented Jan 12 '15, 6:19 a.m.

Hi Sumant,


I tried the below command also, but it is strange that nothing happens,

C:\Program Files (x86)\IBM\JazzTeamServer_5.0.2\server>upgrade\jts\jts_upgrade.bat -oldJTSHome -oldJTSVers
ion 5.0.1 "C:\Program Files (x86)\IBM\JazzTeamServer_5.0.1\server\conf" -updateTomcatFiles no

C:\Program Files (x86)\IBM\JazzTeamServer_5.0.2\server>


Thanks
Anbu


Sumant Renukarya commented Jan 12 '15, 6:20 a.m.
Instead of this:

"C:\Program Files (x86)"\IBM\JazzTeamServer_5.0.1\server\conf

Can you try this?:

"C:\Program Files (x86)\IBM\JazzTeamServer_5.0.1\server\conf"

So it will be:

jts_upgrade.bat -oldJTSHome "C:\Program Files (x86)\IBM\JazzTeamServer_5.0.1\server\conf" -updateTomcatFiles no -oldJTSVersion 5.0.1

Sumant Renukarya commented Jan 12 '15, 6:40 a.m.

Hi Anbu


Please try this again and paste the message received in the output.log, if this fails:

jts_upgrade.bat -oldJTSHome "C:\Program Files (x86)\IBM\JazzTeamServer_5.0.1\server\conf" -updateTomcatFiles no -oldJTSVersion 5.0.1


permanent link
Anbarasu Arivoli (811328) | answered Jan 14 '15, 1:56 a.m.
 Hi,

The script was successful after introducing the short DOS format for Program Files (x86) as PROGRA~2.

jts_upgrade.bat -oldJTSHome "C:\PROGRA~2\IBM\JazzTeamServer_5.0.1\server\conf" -updateTomcatFiles no.

Upgrade to 5.0.2 is successful.

Thanks
Anbu

Your answer


Register or to post your answer.