It's all about the answers!

Ask a question

Where do I find QueryCapability in DoorsNG 5.0.1 with an OSLC request?


Guido Schneider (3.4k1381108) | asked Nov 05 '14, 12:32 p.m.
Within RRC/DoorsNG 4.0.x, I was able to find the "QueryCapability" by reading the service document of the project area by following URL:
/rm/oslc_rm/_tgOWwrPVEeGsn_ToVY7h1A/services.xml     (_tgOWwrPVEeGsn_ToVY7h1A is the PA)
With DoorsNG V.5.0.1 I'm getting only LinkCreationServices, CollectionSelectionDialog and SelectionDialog but not the QueryCapability.

May you give me a hint what has changed and how I now get the QueryCapability?

Accepted answer


permanent link
Mike Jaworski (1.4k6) | answered Nov 05 '14, 1:44 p.m.
JAZZ DEVELOPER
 Hi Guido,

There were a lot of changes to RRC/DNG between v4.x and v5.x, one of the big ones being the adoption of the Jazz Application Framework (JAF). With this adoption, the URL for the OSLC Discovery Service changed, so there may have been some related changes which affected the result of this command (although I don't see any from initially looking through this code). 

All the same, I tried this command in my 5.0.1 environment by entering the URL into the browser window, and I see the same result that you report. After looking through the server code for the OSLC Discovery Service, I found that you should be able to provide either one of these two headers on the request for this URL and get the QueryCapability service you are looking for:

Accept: application/rdf+xml
OSLC-Core-Version: 2.0

This means that you won't be able to get the results you are looking for by executing the standalone URL via the browser window. If you are executing this URL via application code, you should be able to provide these HTTP headers easily; otherwise, I would suggest using an application such as HttpRequester or Poster in order to GET this URL and provide the necessary headers.

Hope this helps,
Mike Jaworski
Guido Schneider selected this answer as the correct answer

Comments
Guido Schneider commented Nov 06 '14, 3:36 a.m.

The trick was the "rdf+", which was not necessary in 4.0.

Accept: application/rdf+xml
Many thanks
Guido

Your answer


Register or to post your answer.