It's all about the answers!

Ask a question

Trying to extend the RTC SCM CLI


Liam Doherty (61) | asked May 12 '09, 6:41 a.m.
Hi

I am trying to extend the RTC core CLI to add new subcommands so to get familiar I used the Wiki page https://jazz.net/wiki/bin/view/Main/SCMCommandLineDevelopment#Building

I have the cli.hello.world in my workspace and it looks clean and I have followed the wiki instructions. In order to do the build I need to use the RTC V2 M3 code, so have set my target platform up to point to C:\RTC-JAZZ\jazz\scmtools\eclipse which is where I have the V2 CLI packages installed.

When I try to do the export I am getting 2 errors. The first relates to the synchronize. I have the synchronize box check and I get the error:

"The plug-in 'com.ibm.team.filesystem.cli.core' is not in the workspace and cannot therefore be modified. Please import it into your workspace and retry."

This is true, it is not in my workspace because I am using a different target environment to pick it up. (My WS is a RTC 1.0.1 BTW).

So I uncheck the synchronize and try again to do the export, except I get the error:

"Unable to find plug-in: org.eclipse.core.net_1.1.0.I20080604. Please check the error log for more details"

This plug-in in is my defined target environment. So does this mean I can't use a target environment to find these plug-ins, that they need to be in my workspace? Plus I can't find anything in the error log.

Help!!

Cheers

Liam Doherty

2 answers



permanent link
Evan Hughes (2.4k1218) | answered May 12 '09, 11:16 a.m.
JAZZ DEVELOPER
I'm not strong in PDE-fu, but I managed to get the CLI to build by setting scmtools as the platform, and then incrementally adding jars from the RTC GUI until it succeeds in building.

permanent link
Liam Doherty (61) | answered May 13 '09, 5:22 a.m.
Thanks Evan for the response. I have got a bit further, possibly as far as you did. I got all of the RTC 2.0 nightly integration code for the full filesystem component and I added that to mu workspace. I then set my target environment to scmtools. Like you I thne added the Client/eclipse plugins to the target enviroment (although not sure why I would need client plugins for the CLI), but that seemed to help.

The next message was in a number of the plugins saying that the org.apache.log4j plugin could not be found. Why would this be, I would have thought if the Cli needed it then it would be included in the scmtools directory. Anyway, I went and found one on my machine and added it to the target environment.

At this point I had a clean (well no errors) workspace. I ran the Export and it worked ok.

I then fell foul of your first common problem when building, namely "In the past I've been bitten by an eclipse bug that prevents the addition of the launcher binary (named 'scm') because the eclipse binary in the TC directory is named 'TeamConcert'. If the export fails without an explanation, or there is no binary, copy jazz/client/eclipse/TeamConcert to jazz/client/eclipse/eclipse. If you're running on windows, add the obligatory '.exe'." So I followed your instructions and it created me an scm.exe.

But when I try and run it with the "help" subcommand it does nothing. So I suspect I have fallen foul of your 2nd common problem when building, namely "If the 'scm' client fails without an apparent reason and doesn't produce output, try copying the 'eclipsec.exe' binary from your workbench directory over 'scm.exe' and running with that."

This also makes sense after doing a google and finding that this kinda related to the console and stdin/stdout not being correctly allocated. However, I do not have a eclipsec.exe on my machine.

So where does elipsec.exe come from? Any ideas how I have progress with this?

thanks for you help.

Cheers

Liam

Your answer


Register or to post your answer.