It's all about the answers!

Ask a question

Running RDz 9.0.1 - Trouble running under z/Linux in the background...


Jean Nelson (62) | asked Sep 23 '14, 12:55 p.m.
I am running RDz 9.0.1 under RedHat 6.4 (s390x).  When I do a   rsed.sh RedHat   and run it in a foreground windows the server start and runs OK. 

HOWEVER , when I do a   rsed.sh RedHat &  to get it to run in the background , I get this in the rseserver.log:
[root@b23zdrwizapp01 log]# cat rseserver.log
Tue Sep 23 10:58:51 EDT 2014
INFO Console Message: FEK004I RseDaemon: Max Heap Size=512MB and Private Size=0MB
---------------------------------------------------------------
Tue Sep 23 10:58:51 EDT 2014
ERROR ZConsoleHandler: FEK004I RseDaemon: Max Heap Size=512MB and Private Size=0MB
---------------------------------------------------------------
Tue Sep 23 10:58:51 EDT 2014
INFO Console Message: FEK010I (rsed.envvars location = /wizmod/IBM/RDz901/bin/)
---------------------------------------------------------------
Tue Sep 23 10:58:51 EDT 2014
ERROR ZConsoleHandler: FEK010I (rsed.envvars location = /wizmod/IBM/RDz901/bin/)
---------------------------------------------------------------
Tue Sep 23 10:58:51 EDT 2014
INFO Console Message: FEK011I (log directory = /wizmod/IBM/RDz901/log/)
---------------------------------------------------------------
Tue Sep 23 10:58:51 EDT 2014
ERROR ZConsoleHandler: FEK011I (log directory = /wizmod/IBM/RDz901/log/)
---------------------------------------------------------------
Tue Sep 23 10:58:51 EDT 2014
INFO Linux on z server version: 8.0.0,  JVM version: 1.6.0
---------------------------------------------------------------
Tue Sep 23 10:58:51 EDT 2014
INFO Invocation parameters: daemon port (4035) , default timeout (120000) , mode (31)
---------------------------------------------------------------
Tue Sep 23 10:58:51 EDT 2014
INFO RseDaemon: startProcesses(): spawn command result=10113:0
---------------------------------------------------------------
Tue Sep 23 10:58:51 EDT 2014
INFO RseDaemon: startProcesses(): send Query to the Server process
---------------------------------------------------------------
Tue Sep 23 10:58:51 EDT 2014
INFO RseDaemon: starting select
---------------------------------------------------------------

I don't get a  server started message. 

And the  ps aux   shows that the   rsed.sh  task is marked terminated.

I believe I have all the  envvars set up OK ...

Just looking for some insite on this.

Thanks!

Be the first one to answer this question!


Register or to post your answer.