It's all about the answers!

Ask a question

Cant Upload attachments to workitem. Attachments dissapear


Cesar Sasaki (511168107) | asked Aug 19 '14, 12:32 p.m.
Hi

I'm using RTC 4.0.6. and in a defect workitem I'm trying to upload an attachemnt at the moment I create it, and it simply "dissapears" the attachment with no error.

What could it be?

Thanks

Comments
Krzysztof Ka┼║mierczyk commented Aug 20 '14, 3:00 a.m.

Hi Cesar,
Couple of clarification questions:
1. For which kind of client (web, eclipse client) do you have the issue?
2. Does it happen for all work items/files? Or there is any pattern?
3. I would start the investigation with Firebug. Please start Firebug and see whether you have any error messages in Firebug console after uploading file.
4. Do you have any corresponding error in ccm.log?
5. When did the issue happen first time? Are you able to figure out what particular actions you had performed just before?


Cesar Sasaki commented Aug 20 '14, 10:32 a.m.

Hi Krysztof

1. The issue is on web client
2. It just happen with 1 type of workitem. Any file.

In my editor I had 2 the "Links" tab where you normally upload attachments and I put another presentation of the attachment on my main tab.
I had disable the attachment presentation on my main tab and it seems to work.

But I have other workitems that have both attachments on main tab and links tab and it works correctly.

I need the attachment on main tab because I'm using itfor defect and needed on the inline editor for RQM

One answer



permanent link
Ralph Earle (25738) | answered Aug 19 '14, 2:26 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER
This might depend on the size of the attachment and the bandwidth available to upload it. If you save the work item before the upload has completed, the upload is canceled without an error message. Before you save the work item, ensure that it displays the attachment as "New" . I tested this in my environment, and do not find any difference between saving an attachment when you first create a work item vs. saving it to an existing work item. 

Comments
Cesar Sasaki commented Aug 19 '14, 3:55 p.m.

Hi Ralph
I dont think it is the size or the bandwidth. I can upload attachments on to different kind of workitem types but not on my defect. It just "dissapear" when I upload and no error is shown.

Your answer


Register or to post your answer.