It's all about the answers!

Ask a question

Cannot connect to Project Area/Repository Connection in Eclipse (RAD) - Connection Failed


Michael Plautz (26711) | asked Aug 19 '14, 12:31 p.m.
edited Aug 19 '14, 4:27 p.m. by Stephanie Taylor (24115)
 I just installed Jazz on a server, and I have the 10 free developer license for RTC (we are using it is a proof of concept to get the business to buy a license).  We did the express setup for Jazz ~ Tomcat and Derby DB.  My Scrum Master created a project area.

I have RAD (IBM Rational Application Developer) 7.5.4 and I was able to install the Jazz plugin.  I went to the Jazz Administration perspective, and I clicked the Connect to Project Area link, and I enter my server information (obscured for privacy):
    https://servername.domain.com:9443/ccm
and a username and password, and I keep getting the message:
    Failed to log into 'servername.domain.com'.
Eventually I get a more detailed error:
    Failed to log into 'servername.domain.com'
    CRJAZ0099I HTTP error "Received fatal alert: handshake_failure" accessing URL "https://servername.domain.com:9443/ccm/service/com.ibm.team.repository.common.internal.IRepositoryRemoteService".

I can access the same https://servername.domain.com:9443/ccm from a web browser just fine, however, the SSL certificate is told to be invalid (I understand that I need to replace the SSL certificate with my company's SSL certificate).  Could this be causing the problem? 

Otherwise, why would it be choking at such a simple step?

Accepted answer


permanent link
Donald Nong (14.4k213) | answered Aug 21 '14, 7:20 a.m.
Try to add "-Dcom.ibm.team.repository.transport.client.protocol=TLSv1" to the .ini file of your RAD/Eclipse. I guess you're using CLM 5.0 which only allows TLS by default. You can also try TLSv1.2 if you're adventurous.
http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m4/topic/com.ibm.jazz.install.doc/topics/t_enable_tls1.2_rtc.html
Michael Plautz selected this answer as the correct answer

Comments
Michael Plautz commented Aug 21 '14, 10:40 a.m.

 I tried this and didn't get a different result.  I use RAD, so I added this line to C:\Program Files (x86)\IBM\SDP\eclipse.ini, which I believe to be correct the .ini file for RAD.  I added it both before the -vmargs and after, and I am getting the same fatal handshake failure.  On a side note, I can just disable SSL (and access CCM from port 9080) and it looks like I'll avoid this issue, but I'd like to stay on SSL if possible.  Are you suggesting that a bad SSL certificate would not be responsible for this?


Donald Nong commented Aug 24 '14, 9:47 p.m.

I have a second look at this and am a bit surprised to see that you could install RAD and RTC together. RAD 7.5 is based on Eclipse 3.4 while RTC (5.0) on Eclipse 3.6.2. How did you manage to put them together? I wonder whether there are some compatibility issues here.


Michael Plautz commented Aug 26 '14, 4:20 p.m.

 There definitely were compatibility issues which I think is what ultimately lead to this error.  Friends of mine at my company got this to work successfully with RAD 8.5, as well as them and I with normal plain Eclipse.  This question outlines the compatibility issues.

Your answer


Register or to post your answer.