It's all about the answers!

Ask a question

RTC Shell Explorer install can't find install-winodws-shell-client.xml file.


Nomaan Ahgharian (812) | asked Aug 18 '14, 5:10 p.m.
I have been trying to install the RTC shell explorer and haven't been successful. 

I have tried 7zip, winrar to unzip the file but none actually helped. 
I tried to put it in the root level of my directory so it doesn't mess up the pathing but still not able to install it.


Please help me get this 'easy' installation done, thank you. 

Comments
Donald Nong commented Aug 26 '14, 3:14 a.m.

Did you actually install the RTC Shell Explorer? Mentioning about different compression tools makes me feel that you only extracted the package but did not install it. To install it, you need to install IBM Installation Manager first, add the extracted package as a repository and then install.


Nomaan Ahgharian commented Sep 05 '14, 1:53 p.m.

I downloaded the installer file so there shouldn't be any need for install manager. I managed to install it, WORST INSTALLATION EXPERIENCE. 

Accepted answer


permanent link
Ralph Schoon (63.0k33645) | answered Sep 08 '14, 2:49 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Sep 08 '14, 4:45 a.m.
You either use the web installer, which will install IBM Installation manager and download the required files, or you use the Installation manager and the Installation Manager repositories.

The easiest way for users with no experience is the web installer.

If you download the plain zip installation manager repository, you have to unzip it to a folder using 7zip and then you have to configure  the Installation Manager File>Preferences>Repositories and point it to the uncompressed folder containing the file repository.config.
Nomaan Ahgharian selected this answer as the correct answer

Comments
Nomaan Ahgharian commented Sep 08 '14, 8:53 a.m.

Raplh, I am afraid that the web installer that you mentioned is the easiest way indeed is not that easy. Windows seems to mess up the pathing so it won't recognize the config.xml or some other xml file. I downloaded the web installer and ended up doing so much that seemed unnecessary. I will add them here later on.  Your answer seem to be in the right direction that I had to follow. There was no official documentation about it so thanks for your answer. 


Ralph Schoon commented Sep 08 '14, 9:26 a.m. | edited Sep 08 '14, 9:26 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I have used the web installer many, many, many times. Countless, really. We tested upgrading several CLM versions and installed from the recent build, not available for download on jazz.net using the web installer and other methods.

Having said that, bad internet connections, confused caching proxies and whatever effects can cause these online installs to fail. I have heard and read from various people, especially in Asia with poor internet connections having problems.

I prefer to download the Plain ZIP files or the ZIPed Installation Manager repositories.
for that reason. The other reason is, I might have the need to uninstall and reinstall for testing and I want to spare me the effort, time and bandwidth to download many times.

So, I use a download manager (as advertized in the download tips) and download those zip files. I wouldn't disagree, that sometimes the documentation could be better.



Ralph Schoon commented Sep 08 '14, 9:31 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

PS: I use 7zip (64 bit) and I have not had this path thing. I also usually try to unzip into a folder that has a short path e.g. D:/install/ and I also use a short path for where I install CLM to. The reason for that is, Windows still has issues with long path names and that could get into the way.

You might want to provide the download location you struggled with. If it is 5.0 I ran through all installs (except the web install) on Windows 7 and haven't come across your problem. Which does not mean it is not happening to you, it is just I was not seeing it.

One other answer



permanent link
Keith Woodard (11) | answered Jun 05 '18, 2:03 p.m.

 I just opened a Help Desk ticket through my company. I believe the IBM errors are bogus and my real issue is a local McAfee Windows firewall blocking issue for outbound \ inbound traffic expected through IBM Installation Manager. It is the only logical supposition that makes sense.

Your answer


Register or to post your answer.