It's all about the answers!

Ask a question

Problems changing process name in RTC 3


Glen Maxfield (936) | asked Aug 07 '14, 6:03 p.m.
A project area was setup using the OpenUP process name.  When I try to use the Plans functions, I get an error saying that planning is not available because the project configuration won't allow it.  I want to change it to Formal Project Management so that we can use plans.

I used the Eclipse client to change the process name, summary, and content path to match another project area that is using Formal Project Management.  The changes saved fine.  But I still get the same error message (below).  What am I doing wrong?

The backlog iteration '/development/backlog' for the timeline 'development' could not be resolved.
com.ibm.team.apt.internal.common.PlanningConfigurationValidator.performValidation(PlanningConfigurationValidator.java:172)
com.ibm.team.apt.internal.common.PlanningConfigurationValidator.performValidationIfNeeded(PlanningConfigurationValidator.java:90)
com.ibm.team.apt.internal.service.IterationPlanService.validatePlanningConfiguration(IterationPlanService.java:1041)
sun.reflect.GeneratedMethodAccessor1028.invoke(Unknown Source)
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
java.lang.reflect.Method.invoke(Method.java:600)
org.eclipse.soda.sat.core.internal.record.ExportProxyServiceRecord.invoke(ExportProxyServiceRecord.java:370)
org.eclipse.soda.sat.core.internal.record.ExportProxyServiceRecord.access$0(ExportProxyServiceRecord.java:356)
org.eclipse.soda.sat.core.internal.record.ExportProxyServiceRecord$ExportedServiceInvocationHandler.invoke(ExportProxyServiceRecord.java:56)
$Proxy858.validatePlanningConfiguration(Unknown Source)

Accepted answer


permanent link
Geoffrey Clemm (30.1k23035) | answered Aug 07 '14, 7:34 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Changing the process name and summary has no effect on the process being executed in your project area.  
I'm not sure what you mean by "content path".  In order to add formal project management features to your project area, see the Knowledge Center page: https://www-01.ibm.com/support/knowledgecenter/SSCP65_5.0.0/com.ibm.jazz.platform.doc/topics/t_customize_template_formal_features.html?lang=en
Glen Maxfield selected this answer as the correct answer

One other answer



permanent link
Glen Maxfield (936) | answered Aug 08 '14, 10:16 a.m.

Thanks Geoff.  I had changed the process description as mentioned in your article, so that confirmed that I was on the right track.

It turned out that I was missing a timeline and iteration of the correct name; I guess that the project areas (from and to) have to have matching timelines and iterations that relate to the tasks you are moving.  Once I had set these up in the target PA, the move worked. 

I also had a problem with Planned For.  Even though I had a plan with the same name in the target PA, I had an error.  So I just set Planned For to Unassigned, saved, and then did the move.  This worked fine.  Of course, I then had to assign the right plan after the move.

A bit painful, but not too bad now.

Your answer


Register or to post your answer.