It's all about the answers!

Ask a question

RTC Team Area Hierarchy and "Project Area" and "Team Area"


Doug Oreilly (2758) | asked May 23 '14, 4:59 p.m.

When I build a Team Hierarchy that looks like this on the Active Project Areas (under overview)

I make something that looks like this I assume to be my "Team Area"

> My Project Name

> My Project Name Child

Issue 1

When I look at a standard report like  "Open Work Items by Type " it gives "No open work items were found"  all I need to do is go in to edit the query Team Area to include "Info not available".  This makes no sense since I just made a team.

Issue 2

I think a related issue is that when looking at a Epic/Story/Task the value for "Team Area"  I would expect to be able to assign my about team (either the parent or child) but I can't change either. 

Accepted answer


permanent link
Don Yang (7.2k2189125) | answered May 25 '14, 6:48 a.m.
From the description, it does not seem that you have associate your team area with any category. you can do that in ccm/admin > category in Web client or in Eclipse client(https://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m3/index.jsp?re=1&topic=/com.ibm.team.workitem.doc/topics/t_defining_categories.html&scope=null)

Basically issue1 and issue2 are the same cause. From your another post, I understand you have run data collection job, since there is no team area associated with category, when creating workitem, filed against will be Project area by default and that's the reason you won't see any team area in the report edit and you have to select Info Not available there which means the default project area.
Doug Oreilly selected this answer as the correct answer

4 other answers



permanent link
sam detweiler (12.4k6175200) | answered May 23 '14, 5:31 p.m.
Reports come from the data warehouse, which is populated only once every 24 hours by default (if you have the data collection jobs enabled)

you assign 'teams' thru the category to team mapping.. workitems (filed against = category)

permanent link
Doug Oreilly (2758) | answered May 27 '14, 10:00 a.m.
 Thanks.

Sam I do have the data collection running (issue on the build but working on that)

Don - you are the man... so to help Identify further to my understanding.

ON the CCM/Admin page.  After you add your categories you then need to update the "Associated Project/Team Area"  which is not an option when you are creating the Categories in the first place.  

I looked at the screen 50 times and that column never jumped out at me.  Thanks!

permanent link
Doug Oreilly (2758) | answered May 27 '14, 2:58 p.m.
 I have made the updates which got the "Project Area" and the "Team area" to update based on what I choose for "Filed Against".

I also got all of the data collector jobs working and run for both JTS/Admin and for CCM/Admin

Under the Associated Project / Team Area I have two different Project/Team

When I go to the reports I still have the box for Team Area, the check mark for "My Team Areas, and the item for Info not available.  None of the categories show up as I would have expected.  so I am still missing something here.



Comments
sam detweiler commented May 27 '14, 2:59 p.m.

Are U a member of those team areas?


Doug Oreilly commented May 27 '14, 3:29 p.m. | edited May 28 '14, 8:57 p.m.

 I am a member of both teams.  


I did this by going to the ccm/admin

Then to the team under the Team Area Hierarchy

Do the process roles matter?  


sam detweiler commented May 27 '14, 3:31 p.m.

roles don't matter.. note that data collected BEFORE the category/team assignment and subsequent etl run will not have the team assignments, so won't show in any team based report.


Doug Oreilly commented May 27 '14, 3:54 p.m. | edited May 28 '14, 8:58 p.m.

So if i have an old item created... change the Filed against it will never populate in the ETL runs?

 Is that where I could run the Full Data collection job?



Don Yang commented May 28 '14, 9:05 p.m. | edited May 28 '14, 9:06 p.m.

I tested here again. before I created any team and associated with any category, the report will show "My Team Area" (checked by default) and Unassigned only under it.
(Unassigned is the same as Info not available).
Then created a new team(team1) > add member > new category(test1) and associated with the new team.
Go to some workitem(task, defect, story) and change the filed against to the new category.
Run CCM only etl jobs(Run all jobs under ccm/admin > reports)
Then I will see:



I got the expected team1 under team area box and test1 is the category associated with team1 in the next box.

Did you do the same thing but did not see the result there?


permanent link
Doug Oreilly (2758) | answered May 29 '14, 9:05 a.m.
Don - It was the categories.  I didn't have the parent one set so all the children were not working.  I'm all set now really appreciate your help..

Your answer


Register or to post your answer.