It's all about the answers!

Ask a question

RPE: Accessing requirement(s) linked to the steps of an RQM Test Case Result


Brian Kranz (311) | asked May 20 '14, 4:42 p.m.
In RQM, we have Test Script steps linked to DOORS requirements (using OSLC).  When the associated Test Case is executed, the resulting Test Case Result shows the requirements in the "Validates" column of each step that had a link to a DOORS requirement at the time the Test Case was executed in RQM.

Using RPE, I'd like to create a document that provides details about a single Test Case Result.  I'd like to report details about each step that was executed, including any requirement that was linked to that step when the Test Case was executed.  The schema from an RQM Test Case Result contains a lot of data about each step, but I don't see where the requirements ("Validates") information is recorded.

From a Test Case Result, how can I configure RPE to get information about requirements that were linked to Test Script steps during the execution?

Thank you,
Brian Kranz

Accepted answer


permanent link
Clara Forero (6212) | answered May 22 '14, 12:51 p.m.
JAZZ DEVELOPER
Hi Brian,

CLM 5.0 includes and enhancement that makes available the requirements linked to an execution result through the new property "executionresult/stepResults/stepResult/requirement".    In the meantime, since the test script is referenced in the execution result, it can be used to get the requirements from the test script and the test script steps (see: https://jazz.net/downloads/rational-quality-manager/releases/4.0.6?p=news#TOC_B_a 
https://jazz.net/wiki/bin/view/Main/RqmOslcQmV2Api#Test_Script_Step).

Thanks,
Clara
Brian Kranz selected this answer as the correct answer

Comments
Brian Kranz commented May 23 '14, 12:45 p.m.

Hi Clara,

Thank you for the information.  I am glad to hear that CLM 5.0 will have the enhancement you described.

I had already performed your suggestion and used the test script referenced in the execution result to get the requirements from the test script steps.

This works well as long as the test script has not changed since the execution result was created.  However, if the test script is updated (steps added/deleted/moved or requirements added/deleted) after the execution result, the data therein is no longer valid for the execution result.

I look forward to the enhancement in CLM 5.0.  It sounds like it would contain accurate requirement data for a test script at the time the test script was executed.

Thank you,
Brian


Jamie Berry commented Jan 27 '16, 11:35 a.m.

 Clara,


  I am trying to do the same type of RPE template as Brian and I still do not see the requirement linkage at the executed step level in RQM version 5.0.2 with RPE 1.2.1.1. The RPE data source schema has the new property "executionresult/stepResults/stepResult/requirement", but it doesn't appear to be in the XML returned when retrieving the data.  Is there something else we need to do in order for the linkages to requirements to show up at the test script step level in the test case execution results?   We can still use the workaround, but we really need to be able to report what the script was at the time of execution not at the time of the report.

Thank you,
Jamie

One other answer



permanent link
Clara Forero (6212) | answered Jan 27 '16, 11:57 a.m.
JAZZ DEVELOPER
Hi Jamie,

I found this note on the documentation of the REST API: "For performance reasons, including the qm:executionresult/executionresult:stepResults/er:stepResult/er:requirement property also requires the following fields filter: <feedUrl>?fields=feed/entry/content/executionresult/stepResults/stepResult/requirement". 

Could this be what is missing? If the note doesn't help, could you please create a new forum question and tag it as related to the REST API?  This way, an expert in the RQM REST API should be able to assist you.

Thank you,
Clara F.

Comments
Jamie Berry commented Jan 27 '16, 12:41 p.m.

 Thank you for the reply.  I tried adding the fields entry as you mentioned and it still isn't returning the data using Poster in FireFox.  I will go ahead and submit a new forum post and tag it for the REST API and RPE since I need the result back in RPE and it usually takes care of constructing the needed field arguments to the queries.


Thanks again,
Jamie.


Jamie Berry commented Jan 27 '16, 5:30 p.m.

 Clara,


  I did make a new post and then kept playing around with the URL formatting.  I finally constructed URLs that worked see forum question 215310.

Thank you again for your advice.
Jamie.


Clara Forero commented Jan 27 '16, 5:42 p.m.
JAZZ DEVELOPER

You're very welcome. I'm glad it's working now!

- Clara

Your answer


Register or to post your answer.