It's all about the answers!

Ask a question

Silent install of WAS for RRDI on Linux, all 64 bit.


Mike Shkolnik (9657155143) | asked May 02 '14, 1:48 p.m.
The goal is to install 64 bit WebSphere Application Server and 64 bit RRDI on the same 64 bit Linux server using a silent install via PuTTY. 
 
Here is what I have: 
 
1.       The 3 WAS 8.5 zip files, unzipped into a single folder “/opt/app/INSTALL/WAS85” on the 64 bit Linux server. 
2.       The RRDI zip files “RRDI-Web-Installer-Linux-2.0.6.zip” and "RRDI-repo-Linux64-2.0.6.zip" unzipped into separate folders “/opt/app/INSTALL/RRDIweb” and “/opt/app/INSTALL/RRDIrepo”. 
3.       Intended destination folders created – “/opt/app/WAS” and “/opt/app/RRDI”. 
4.       Installation Manager 1.7.2 installed (not just unzipped) on the 64 bit Linux server intended for WAS and RRDI. 
5.       The Content Store database (named “CS” and running on MSSQL 2008) has been created on the same DB server containing the other RTC databases. 
6.       RTC 4.0.6 is installed and running fine on a 64 bit Linux Tomcat server separate from the WAS/RRDI server. 
 
Where do I start with installing WAS 64 bit for Linux using a silent install? It appears I need to create a response file called “linux_single_server.rsp” but the file does not yet exist. Anything I have found on the topic is either for a different version of WAS or intended for someone who already knows WebSphere, which I don’t. I do have experience doing silent installs of RTC on 64 bit Linux via PuTTY and can likely figure out the RRDI install based on that experience. But WAS is different... A response file specifically intended for an RRDI install (on the same Linux server, all 64 bit) would be of great help.

3 answers



permanent link
Donald Nong (14.4k313) | answered May 06 '14, 1:14 a.m.
Unless you are a system administrator and need to deploy multiple server, I don't see the point of silent installation as it gives the opportunity to install the product the same way repeatedly. Also, the fact that you don't know how to install WAS does not help you to create a response file either.
Since you mentioned PuTTY, I suspect that you just want to install the product in "console mode". If that's the case, check out the document below.
http://pic.dhe.ibm.com/infocenter/install/v1r7/topic/com.ibm.cic.agent.console.doc/topics/c_console_mode.html
Alternatively, install VNC Server on the Linux server and you will have a nice GUI of Installation Manager in your VNC Viewer session.

Comments
Mike Shkolnik commented May 06 '14, 2:25 p.m.

I don't have permissions to install VNC. Indeed, I need commandline install, not necessarily silent install. With RTC, the commandline install is called the silent install. Perhaps WAS is different. Thanks for the link.


Mike Shkolnik commented May 06 '14, 6:56 p.m.

Looks like I am back to creating a response file. I tried console mode and got this:

"ERROR: The package IBM WebSphere Application Server 8.5.0.0 (8.5.0.20120501_1108) does not support being installed in console mode."


Donald Nong commented May 06 '14, 8:26 p.m.

OK. It seems that console mode is not an option for you. WAS document clearly says that console mode is not supported, and the first version to support console mode appears to be 8.5.5.1 but it is not compatible with RRDI 2.0.6.

For WAS 8.5.5 version, WAS needs to be at version 8.5.5 without any additional Fixpack.
How unlucky you are!
Unless you are quite experienced, it is not easy to create/modify a response file in a text editor, which means that you need to use Installation Manager in GUI mode to create one. So you are back to square one. I think you have to two options here.
1. Ask the system administrator to install VNC server for you.
2. Find another similar Linux machine and run Installation Manager there to create a response file.


Mike Shkolnik commented May 07 '14, 6:54 p.m.

Commandline mode appears to be separate from console mode. However, commandline mode is complaining about my use of 64 bit Installation Manager, even though I am trying to install the 64 bit WAS. I am missing a parameter or something.


Donald Nong commented May 07 '14, 10:05 p.m.

That's a different issue. Even 64 bit CLM complains about 64 bit Installation Manager. You can either ignore the warning or use a 32 bit Installation Manager. You don't need a 64 bit Installation Manager to install 64 bit point products.


permanent link
Marcel Dextraze (1) | answered May 05 '14, 5:50 p.m.
JAZZ DEVELOPER
I will try to find something to help you but, the first thing, I noticed that you downloaded and unzipped both the RRDI Web Installer and RRDI Local repository. They are mutually exclusive. RRDI Web Installer will connect to a web repository located on Jazz.net. The RRDI Local repository is the install repository itself, in this case for Linux 64 bit platforms only, that Installation Manager can use to install RRDI. I recommend that you use that one and delete the RRDI Web Installer, installation will be faster... Come back to this thread later for more hints for silent installation.

Comments
Mike Shkolnik commented May 06 '14, 2:27 p.m.

With RTC, both install files are used. The configuration of the silent install is taken from the web install folder. Basically you make a change to the config file to tell it to pull files from the repo folder instead of the web. Perhaps WAS is different?


Mike Shkolnik commented May 12 '14, 1:35 p.m.

I meant "perhaps RRDI is different"...


permanent link
Cheng-Yee Lin (611) | answered May 05 '14, 6:44 p.m.
JAZZ DEVELOPER
For the WAS silent installation, the following 2 topics in the WAS 8.5 information center may help:

    http://pic.dhe.ibm.com/infocenter/wasinfo/v8r5/topic/com.ibm.websphere.installation.base.doc/ae/tins_installation_dist_silent.html
    http://pic.dhe.ibm.com/infocenter/wasinfo/v8r5/topic/com.ibm.websphere.installation.base.doc/ae/tins_installation_dist_cl.html


Comments
Mike Shkolnik commented May 06 '14, 7:20 p.m.

Thanks. I tried commandline mode but got the following error:

"CRIMA1137W WARNING: The following packages do not support the 64-bit version of Installation Manager that you are using: IBM WebSphere Application Server version 8.5.0.0. If you continue, you might have issues with installation and deployment. For information about 64-bit mode support for a package, see the package documentation."

This is what I typed:
"./imcl install  com.ibm.websphere.BASE.v85_8.5.0.20120501_1108 -repositories /opt/app/INSTALL/WAS85 -installationDirectory /opt/app/WAS"

The repository is supposed to be for either 32 or 64 bit. Is there some special way to specify 64 bit for a commandline install of WAS 8.5? Perhaps with "-properties" or "-preferences"?

These are the repository files I am using (unzipped into one folder):

IBM WebSphere Application Server V8.5 (1 of 3) for Multiplatform Multilingual (CI6XNML)
IBM WebSphere Application Server V8.5 (2 of 3) for Multiplatform Multilingual (CI6XPML)
IBM WebSphere Application Server V8.5 (3 of 3) for Multiplatform Multilingual (CI6XQML)

Your answer


Register or to post your answer.