It's all about the answers!

Ask a question

Why Can't I Add com.ibm.team.repository.common in the Extensions Workshop?


Nate Decker (37812753) | asked Apr 04 '14, 7:54 a.m.
edited Apr 04 '14, 8:11 a.m.

I have recently been trying to go through the extensions workshop so that I can develop some custom operational behaviors. When following the tutorial, I ran into an issue where the tutorial was directing me to specify a plug-in dependency of "com.ibm.team.repository.common". Presumably, this plug-in is part of the SDK. Although I've unzipped the 4.0.6 SDK and have added all of the files to my jazz search like the tutorial directs me to do, I am unable to add that specific plug-in to the project dependencies list. There are several plug-ins that have that name listed as their prefix, but they have other words tacked onto the end as well so they aren't the exact plug-in that the Workshop directs me to use.

I tried just skipping that particular plug-in, but then some of the code from the Workshop doesn't work because it evidently specifies data types that are defined within that particular plug-in. I have a coworker who has successfully gone through this workshop and he is able to add the indicated dependency without a problem. The only difference I can think of is that he started it using the 4.0.4 SDK. I don't know if that's the issue or not though. When I visually scan through the list of plug-ins that were loaded when I changed my target to the SDK, I can see the desired plug-in in the list. It just isn't offered as an option from within the "Dependencies" tab of my project.

Has anyone had this issue? Can anyone tell me how I can get the missing dependency to show up?


Comments
sam detweiler commented Apr 04 '14, 8:23 a.m.

on my 4.0.5 sdk the filename is 


sdk/plugins/com.ibm.team.repository.common_1.3.3000.v20131022_0156.jar 

the one with no text after 'common' (rest is numbers) is the one u want


Nate Decker commented Apr 04 '14, 8:26 a.m.

Yeah, I see a similarly named one as part of the 4.0.6 SDK, but it's not listed as an available option when I click on the "Add" button on the dependencies tab of the Manifest file. It just doesn't come up as a search result when I type: com.ibm.team.repository.common. I get a bunch of the other ones, but not the one that ends in "Common" (ignoring the version number string that follows the name).


Nate Decker commented Apr 04 '14, 8:37 a.m.

Oh I didn't realize you could do this manually. Can you elaborate on this? Do you just type in the name of the plug-in under the "MANIFEST.MF" file? It looks like there are some "Require-Bundle entries that I could add to. I would just need to figure out what the correct "bundle-version" info to use. I'll investigate this. Thanks.


1
sam detweiler commented Apr 04 '14, 8:40 a.m.

I was going to add that same direction as Susan

I just edit the manifest.mf file

Require-Bundle: com.ibm.team.process.common,
 com.ibm.team.workitem.common,
 com.ibm.team.repository.common, 


Nate Decker commented Apr 04 '14, 8:42 a.m.

Susan and/or Sam, I think your suggestions will work for me. I'd like to give you credit and mark your response as the answer, but as a comment on my question rather than an "answer", I cannot do so. If you want to convert your comment to an answer, I'll mark it as answered.


Ralph Schoon commented Apr 04 '14, 8:57 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Nate,

I have done this myself in the past too, for various reasons. You need to be a bit careful with the manifest file especially at the end of the list. If you don't manage to get the format right, the manifest file might break (you see an error indicator). Thisis more for others that might try this, as it worked for you.

showing 5 of 6 show 1 more comments

Accepted answer


permanent link
Susan Hanson (1.6k2167193) | answered Apr 04 '14, 8:34 a.m.
I've seen that as well and I have no idea why (I was on 4.0.5).  I went in and manually added it into the manifest file.

Susan
Ralph Schoon selected this answer as the correct answer

Comments
Ralph Schoon commented Apr 04 '14, 9:07 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I think we need to find a better balance on what is an answer and what is a comment. It is also possible to change a comment to an answer. Not sure if that is tied to reputation. Use teh icons to the right of the name of the commenter.


sam detweiler commented Apr 04 '14, 9:47 a.m. | edited Apr 04 '14, 9:49 a.m.

i try to use comment first, so that we can have a dialog, and answer later. I try not to presume that my response will satisfy the requestor's query. I use answer when I have already done so, and someone has selected (validated) my response. 


as I've said many times before, we should not have this distinction to deal with.  An 'accepted answer' is a comment that has one more attribute. an 'unaccepted answer' is a comment. 

One other answer



permanent link
Ralph Schoon (55.3k23642) | answered Apr 04 '14, 8:37 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
I am not sure what issue you have. Probably an issue with the setup itself. I was able to set up the ADK in 4.0.6 and am able to add the dependency - note the typing in the filter - make sure to not mistype and be aware some packages have .report. in the middle:



Comments
sam detweiler commented Apr 04 '14, 8:41 a.m. | edited Apr 04 '14, 8:44 a.m.

on my 4.0.4 I don't see it in the choices either..  


but it is clearly in the sdk/plugins folder which is set as my current plugin target platform


Ralph Schoon commented Apr 04 '14, 8:52 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Odd, I am not sure what the problem could be. It btw only shows it is not yet added.It might take some time to load the plugins list. There is also a view in the plugin perspective, where you can list the plugins available.

It should be there, if not, something would be severely broken in the SDK.


sam detweiler commented Apr 04 '14, 8:54 a.m.

I've never seen any delay here

Your answer


Register or to post your answer.