It's all about the answers!

Ask a question

How to make a project available to fork?


Joseph McCarthy (622) | asked Feb 19 '14, 6:38 p.m.
I've created a public project, but whenever anyone goes to fork it, they're only seeing the project.json file, not the rest of the code. I've searched around and can't find any documentation on how to make a project available for users to fork, is there something ridiculously simple I'm missing?

Thanks

4 answers



permanent link
Ralph Schoon (61.4k33643) | answered Feb 20 '14, 5:57 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Joseph,

are you talking about a stream in the JazzHub SCM?

There was an issue that I ran into recently that looked similar.
You should be able to see the following page - if you go to edit code


There you should be able to connect to the repository, select a stream and create a repository workspace and load in in the web UI.

I would suggest to contact support if you only see the Project.json file, This would help them to track down the problem. I did and my similar problem went away and we are not sure what happened.


Comments
Lauren Hayward Schaefer commented Feb 20 '14, 6:54 a.m.
JAZZ DEVELOPER

After you've made sure you've loaded your repository workspace, also check that you have delivered your changes.  You can deliver your code by hovering over the second icon on the left that looks like a repository and selecting Jazz SCM Changes. From there, check in your changes and deliver them.


Millard Ellingsworth commented Feb 20 '14, 10:56 a.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

@lhayward So, given the scenario, it seems the issue is that forking will only copy delivered changes. The project.json file is "delivered" by default, I expect. I'm guessing the (internal) flow is (1) create stream and populate with initial files, e.g., project.json and (2) pull stream into project creator's workspace. Since it's possible to deploy from the workspace, it isn't always clear (without specifically going to the SCM page) that these changes are not visible to others.


Lauren Hayward Schaefer commented Feb 20 '14, 11:03 a.m.
JAZZ DEVELOPER

When a user tries to access your code in the JazzHub editor, a workspace is created for that user.  The workspace contains code that has been delivered to the project. 

I believe that if the user tries to view the code again, his workspace will be the same as what he viewed previously.  Therefore, he may need to accept any new changes by going to Jazz SCM Changes and choosing to accept the latest.


Ralph Schoon commented Feb 20 '14, 11:12 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Millard, I think you should not see the file project.json. You should see an empty repo workspace and be able to create and share projects. If you see that file this is a bug similar to the issue I had. I had to jump several hoops to be able to see my repo workspace again. I disconnected the repository, reconnected and at some point I was able to see my streams and workspaces again. Then I was able to load the workspace and see the files.


permanent link
Raymond Clement (1338) | answered Mar 22 '14, 10:30 p.m.
This problem has been driving me nuts, but I figured out how it is happening.

After a user clicks EDIT CODE on the project they plan to fork, the four icons (pencil, cylinder, magnifying glass, and command prompt window) appear on the left and the center screen is briefly blank. A box then appears in that blank area named <user> | <Project Name> with the Repsitory URL info. A little while later two boxes named Streams and Repository Workspaces appear.

The problem is that users click the pencil icon -> Show Current Folder. That is the wrong thing to do at this point! All a user will see here is the project.json file. I was not patient enough to see the three boxes appear. The correct step is to click the Load workspace icon under the Repository Workspaces box. Once that is complete, users can click pencil -> Show Current Folder.

If a user is in the weird state of only seeing the project.json file, they must click cylinder -> ALL Jazz SCM Repositories. Locate the project in question, and press the red X button to delete. Click OK in the dialog box that opens. Now start over and have patience.

Comments
Ralph Schoon commented Mar 24 '14, 3:40 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Thanks for figuring that out. I ran into the same trap.


permanent link
Joseph McCarthy (622) | answered Feb 20 '14, 12:16 p.m.
these are the steps I'm following
  • make changes in code
  • click repositories link (second image link on left, as specified by Lauren)
  • expand "Workspace Changes"
  • Review changes and click "Deliver change set(s) to the stream" link on the "Workspace Changes" bar (it looks like a triangle with an arrow pointing up coming out of it)
When I click "Edit Code" in the top right, a green bar that says "Loading" appears and then nothing happens
I'm using firefox 27.0.1 and have tried it with all add ons disabled with the same results

Comments
Lauren Hayward Schaefer commented Feb 20 '14, 12:23 p.m.
JAZZ DEVELOPER

From your bulleted list, it sounds like you have delivered your changes.

Are you saying that after delivering changes, you're no longer able to access the JazzHub code editor?

After delivering your files, are others still not able to view your code?  If that is still a problem, have them go to Jazz SCM Changes and accept your changes.


Joseph McCarthy commented Feb 23 '14, 8:46 a.m.

no, I can access the code, but other users cannot see my changes. 


I've tried accepting the changes in the Jazz SCM view, but the changes are still not available 


Lauren Hayward Schaefer commented Feb 24 '14, 2:39 p.m.
JAZZ DEVELOPER

I see one of the answers has been marked as correct.  Is your problem solved?


permanent link
McQ Wilson (613) | answered Mar 24 '14, 8:05 a.m.
FORUM ADMINISTRATOR
Thanks to all who are working through this. We clearly need to improve the UX both around working with Jazz SCM repositories and on forking. I'll make sure the effected teams see this thread.

Your answer


Register or to post your answer.