It's all about the answers!

Ask a question

Timesheet ETL in Rational Insight 1.1.1.2 and CLM 4.03


Kunal Bajaj (26510) | asked Feb 18 '14, 5:46 p.m.
Were the Timesheet reporting ETLs a part of Rational Insight 1.1.1.2? I see conflicting posts on this. Can someone from IBM please respond and confirm what the current status is? 

If this was not rolled out, is there a work around or a patch? Thanks.

4 answers



permanent link
Francesco Chiossi (5.7k1719) | answered Feb 19 '14, 6:13 a.m.
Hello Kunal,

this is what I found in the last version of the info center:

Note: For Data Manager, the Timesheet job is included in the Work Item job and is disabled by default. An additional job, Timesheet4.0.3_FullLoad , is included. You must run this job before enabling the Timesheet job within the Work Item job.
See:

Running the data collection jobs
http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m5/topic/com.ibm.rational.reporting.admin.doc/topics/t_running_the_data_collection_jobs.html

Best Regards,

Francesco Chiossi

permanent link
Kunal Bajaj (26510) | answered Feb 19 '14, 10:33 a.m.
 Francesco,

Thanks for the response. The link you mentioned is for Rational Reporting 4.05. In Rational Insight 1.1.1.2, in Data Manager, there does not appear to be a Timesheet4.0.3_FullLoad job. Would you be able to provide the location of this job? If it is not included, is there a way to export the job from your environment and import it into ours?

permanent link
Marc Nehme (27657) | answered Feb 20 '14, 12:38 p.m.
JAZZ DEVELOPER
edited Feb 20 '14, 12:41 p.m.
Hi Kunal,

The Timesheet job is indeed there for RTC v4.0.3. First, ensure that you are using the updated .PKG file for RTC v4.0.3 which can be downloaded from your ccm/admin > Reports page. http://pic.dhe.ibm.com/infocenter/rentrpt/v1r1m1/index.jsp?topic=%2Fcom.ibm.rational.raer.integration.doc%2Ftopics%2Ft_integrate_clm_package.html

Once you ensure you have downloaded that PKG file and imported it into your Data Manager catalog, in Data Manager, navigate to Builds and Jobstreams > Jobs > RTCJobs > RTC4.0.3Jobs and you will find the RTC_Timesheet4.0.3 job there.



It is disabled by default and referenced in the RTC_Workitem4.0.3 job:


Comments
Marc Nehme commented Feb 24 '14, 3:27 p.m.
JAZZ DEVELOPER

Kunal, it appears there is some confusion with the versioning of the jobs. I was looking at my 405 catalog when I replied above. The 405 catalog shows the Timesheet jobs nested and labeled 403 (see pic above). The 403 Timesheet job also references 401 builds. I am getting clarity from Dev on this confusing nomenclature. Apologies for the confusion. I would think if the builds were only available in 404, then we would label them with v404 and not 403. We will update you through PMR once we get some clarity from Dev.


Marc Nehme commented Feb 24 '14, 4:36 p.m.
JAZZ DEVELOPER

Kunal, please contact Support to see if you can get an export of the Timesheet job so you can import it into your environment. Dev confirmed will run against a 403 environment.


permanent link
Marc Nehme (27657) | answered Mar 05 '14, 4:27 p.m.
JAZZ DEVELOPER
Kunal, I have tested this and it works fine. You need to obtain the Timesheet job package from support and import it. Run the full load (RTC_Timesheet4.0.3_FullLoad) the first time. Once that completes successfully, append "RTC_Timesheet4.0.3" it to the RTC_Workitem4.0.3 job as the second to last node before the "Finish" procedure.

Comments
Marc Nehme commented Mar 17 '14, 2:09 p.m.
JAZZ DEVELOPER

Please note that IBM has confirmed that this is indeed considered a customization and you must own the solution. If you are interested in implementing this, please do not open a PMR with IBM Support. I have listed the process on how to implement this in my blog: http://marcnehme.com/blog/?p=89

Your answer


Register or to post your answer.