It's all about the answers!

Ask a question

RQM export to csv function doesn´t working


Diego Superbi (15913) | asked Jan 30 '14, 7:49 a.m.
Hello.

I'm trying to export Test Cases to csv format, but the process never finish. I tried to did it with 200 Test Cases, but after one day, the export status didn't change, the progress bar stayed on 0%.  

Any idea about what might be happening?


Thank you!

Diego Superbi

2 answers



permanent link
Erica Tran (1.4k7) | answered Jan 30 '14, 11:11 a.m.
JAZZ DEVELOPER
Diego,
What version of RQM are you using?  Also, what does the export job queue look like?  Here is a link to the info center about managing the queue.  Managing the Export Job Queue

Since it has been running for a day, its probably not going to complete, so I suggest cancelling the job, and trying another export.  I would test with a smaller view or other artifacts to help narrow down the problem.

Comments
Diego Superbi commented Jan 30 '14, 11:56 a.m.

Thank you for your answer Erica.

I'm using RQM 4.0.3. The export job status is always queued. It never change.

I'd canceled all the queued jobs, and tried to export it again, but it stay queued again.

I've been using its export function for a week, without any problem. But since today morning it isn't working anymore.


Erica Tran commented Jan 30 '14, 11:59 a.m.
JAZZ DEVELOPER

Hi Diego,
Is there anything else that's stuck in the queue?  It appears there is a problem with the export.  When you perform the export, are there any errors in the log?  What's in the qm.log?


Diego Superbi commented Jan 30 '14, 12:56 p.m.

Hi Erica.

I didn't identify anything else.

In the log, it is presented many lines, but none of them related directly with this export behaviour, I'm sending you some of the lines:

2014-01-30 15:44:30,695 [WebContainer : 31 @@ 15:44 RRASSIS /qm/service/com.ibm.team.dashboard.common.internal.service.IProjectMemberService/photos]  WARN m.team.repository.service.internal.LogFeedAppender  - CRJAZ2649I Atualmente, um alto volume de mensagens está sendo registrado. Para manter o desempenho, o servidor não está replicando algumas mensagens no banco de dados. No entanto, essas mensagens continuam disponíveis neste arquivo de log.
2014-01-30 15:44:30,976 [WebContainer : 31 @@ 15:44 RRASSIS /qm/service/com.ibm.team.dashboard.common.internal.service.IProjectMemberService/photos]  WARN com.ibm.team.dashboard                              - Unhandled Exception
java.lang.IllegalArgumentException: invalid UUID



Erica Tran commented Jan 30 '14, 1:26 p.m.
JAZZ DEVELOPER

Hi Diego,
Those errors don't look related to the problem.  I would look earlier in the log to see if you see anything when you first tried the export.  If this doesn't help, I suggest you open a PMR for support to help with the investigation.


permanent link
Vidya Malkarnekar (1.0k15) | answered Jan 30 '14, 3:42 p.m.
JAZZ DEVELOPER
Hi Diego,
 
Since the pdf/csv exports worked in the past, there could be a deadlock in print framework preventing new jobs to run now. If restarting the QM server is possible, then try that to see if it resolves the issue. Alternatively, you can log into each project

  1. Navigate to the Export Job Queue
  2. select the "Show All Export Jobs" check box
  3. select all export jobs
  4. click the delete button

You will need to have "Administer Print Jobs" permission (specifically "view" and "delete") to complete these steps.  This will be tedious if you have many projects.

Otherwise, you can open up a PMR with IBM support for further investigation.

Your answer


Register or to post your answer.