It's all about the answers!

Ask a question

How do I separate the Summary from the Type in the Eclipse Work Item View?


Susan Hanson (1.6k2173193) | asked Jan 07 '14, 10:25 p.m.
I swear I used to be able to do this, but I can't seem to figure it out now.

When I do a work item view (like running a query), my Summary and Type icon area always stuck together.  This makes it impossible (it would seem) to get the "Synchronize Attributes" menu option to appear since it looks like it thinks it is the Summary attribute and not the Type attribute.

I've tried to change the order of the attributes and the selected columns to not display the Summary, for example, but nothing seems to work.  Even if I don't select "Summary" as a selected column to display in my query, it displays the Summary anyway, along with the Type icon.  For example:
 

Gives me this


How can I get rid of the Summary, or separate the Summary from the Type??


Comments
sam detweiler commented Jan 07 '14, 10:55 p.m.

make sure you don't have one of the extra views selected..
in the down arrow dropdown in the workitem view window


Susan Hanson commented Jan 08 '14, 12:20 a.m.

Yea, I thought of that.  When I do the little drop arrow to select the columns, sometimes I can't even de-select the summary at all, and when I can, even if I de-select it from that menu, it still remains in the view.  So with the same query above and same view, this is what that Columns menu looks like:


Summary is NOT selected, and even shown as grey.  But again, I can't get RID of it.

I thought somewhere there was an option to show them together but I can't seem to find it to save my life now.


sam detweiler commented Jan 08 '14, 6:58 a.m.

if you select relationships, turn off the packaging summary workitem selection


sam detweiler commented Jan 08 '14, 6:59 a.m.

the workitem results view configuration is eclipse side, not query wide.. so if you set some config today, it will be used on all query results til you change it again,,


Susan Hanson commented Jan 08 '14, 7:10 a.m. | edited Jan 08 '14, 7:10 a.m.

Yes, I know it is eclipse-wide but I had just created a simple query just to show it easier.  It has to be a setting somewhere .. I have another 4.0.0.1 Eclipse Client on a server in Raleigh that I can remote desktop to and it does NOT have the two attributes combined in the Work Item View.

And the Packaging Summary Workitem selection wasn't it.  I didn't have it selected and if I selected and then deselected, no change.

Susan


sam detweiler commented Jan 08 '14, 3:40 p.m.

and sometimes you have to CLOSE the workitems results view and re-request (not just refresh) the list to get the corrected view.. I had that happen to  me today. 

showing 5 of 6 show 1 more comments

2 answers



permanent link
sam detweiler (12.4k6177201) | answered Jan 08 '14, 7:39 a.m.
in the workitem view, down arrow, select relationships, not columns, and deselect
'packaging summary workitem' selection

least that is what combines/separates the icon and summary fields

permanent link
Susan Hanson (1.6k2173193) | answered Jan 23 '14, 8:30 a.m.
Okay, figured this out .. it was that in my Select Relationships, I was showing Children.

Your answer


Register or to post your answer.