It's all about the answers!

Ask a question

How to switch localization to English on machines with different regional settings.


1
1
Ralph Schoon (63.0k33645) | asked Mar 04 '09, 5:14 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Aug 09 '16, 4:07 a.m.
Hi,

I have read conversations about how to do it, but seem to be unable to figure
the whole truth:

I have RTC 1.0.1.1 installed from a zip file on my machine, both client and
server.

I start RTC using this command: TeamConcert.exe -nl en
I used to also have a VM argument

-Duser.language=en_US

in the teamconcert.ini this worked for me fine in the past. However with
this release and the german nationalization installed from the zip file RTC
seems to get confused.
The main menus are in english but I still see (pretty funny) german expressions
for instance in events and in some other areas.

Can anyone please be a bit more specific on where to supply what flag to
get my RTC back to proper english?

Many thanks in advance!

Ralph

Accepted answer


permanent link
Ralph Schoon (63.0k33645) | answered Jul 14 '12, 8:38 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Aug 09 '16, 4:08 a.m.
Since this still seems to be puzzling to many people, here what I do today:

I want an English UI, but without intervention Jazz provides a mix of German and English on my machine with German regional settings.

To prevent that, I do the following:

I add -Duser.language=en as parameter to
 - The application server environment e.g. adding set JAVA_OPTS=%JAVA_OPTS% -Duser.language=en to the server.startup.bat
- The eclipse.ini, the jbe.ini, the scm.ini
- The Web UI detects the browser language and tries to provide localized content, so I switched my browser to English settings using the Quick Locale Switcher (FireFox)

It is also wise to make sure to create projects using the English process templates.

In principle this is also true for all the other CLM applications.
Ralph Schoon selected this answer as the correct answer

One other answer



permanent link
Krzysztof Ka┼║mierczyk (7.4k372103) | answered May 13 '13, 11:20 a.m.
Hi Ralph,
Good article! I just wanted to say that if you are using WAS, you must perform following additional steps:

  1. In the WebSphere Integrated Solutions Console, click Servers > Server Types > WebSphere application servers > Server1.
  2. Under Server Infrastructure, click Java and Process Management > Process definition.
  3. Under Additional Properties, click Java Virtual Machine.
  4. In the Generic JVM arguments field, add following parameter:
    -Duser.language=en


Comments
Ralph Schoon commented Jul 19 '16, 4:08 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Thanks Krzysztof!

Your answer


Register or to post your answer.