It's all about the answers!

Ask a question

getting bad request error using rtc camera through RTC web client


deepak bora (1111) | asked Dec 05 '13, 9:44 a.m.
In a rtc project area, some users are getting bad request error using RTC camera feature to save screenshot as attachment. RTC server version is 4.0.3

Comments
Krzysztof Kaźmierczyk commented Dec 05 '13, 10:47 a.m.

Hi Deepak,
Did you use RTC Eclipse client or web browser? Could you past screen shot with error message here?


Millard Ellingsworth commented Dec 05 '13, 6:05 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

And if the web UI, which browser(s) and version(s) have you tried? 


deepak bora commented Dec 06 '13, 3:26 a.m. | edited Dec 06 '13, 3:30 a.m.

error scresnshot

I have tried in both IE8 and firefox 12, i am facing this error in a particular project area. Well i am a jazz admin.


Ralph Schoon commented Dec 06 '13, 8:11 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Being Jazz Admin does not give you all permissions. It only overrides some specific permissions e.g. to make you member of a project, to give yourself a role or create one and to save the project areas process, even if you don't have a role with the permission to do so.

Try to add yourself as a member of the project with a role that has permission to save the attachment on the work item.


deepak bora commented Dec 09 '13, 9:11 a.m.

when i add myself in the team area as team member i was getting bad request on using rtc camera but i was able to add any attachment directly.
then i add myself as team member in the project area then rtc camera works.
Could you explain the reason


Ralph Schoon commented Dec 09 '13, 9:22 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I tried to explain what I think happens already above. Just being an admin does not provide you with any permissions on a project area, except being able to save the project area and giving yourself roles. If you want to create and save a work item with an attachments, you are still checked against the permissions. If you are no member and have no role, your permissions are essentially the permissions of the "Everybody" role. If that role does not have the correct permissions to save a work item or an attachment, this will fail for you.

showing 5 of 6 show 1 more comments

Be the first one to answer this question!


Register or to post your answer.