It's all about the answers!

Ask a question

Installation issue - jazz server not up


Janardhanam Venkat (611) | asked Nov 21 '13, 1:44 a.m.
edited Nov 21 '13, 1:46 a.m.

I installed Jazz server using Express Installation from Rational Doors Next Generation. The express installation  launched IBM Installation Manager, picked Jazz server, Quality Management and Requirement management.

During the installation process I mentioned that I have Tomcat already installed and picked the webapps folder from my existing installation. Once the installation is complete I started Tomcat and hit the URL to configure the jazz server as mentioned in the doc. Clicking on http://venkat-lt7.maa.corp.collab.net:9443/jts/ I got page not found. Looking at logs could not see any error. My other apps in webapps folder are working except this one.

I uninstalled two times followed instructions line by line and still the same issue. I am installation on Windows 7,  64bit box for evaluation.

Why the documentation is so bad?

Any help is appreciated.


Comments
Sumant Renukarya commented Nov 21 '13, 5:50 a.m.

Given the fact that there are so many things involved here w.r.t installation, reusing an existing Apache Tomcat server and you haven't been able to figure after reinstalling twice you should perhaps consider raising a PMR with Rational Support. 


I believe this needs a detailed troubleshooting to find the root cause and resolve.


Karl Weinert commented Nov 21 '13, 10:28 a.m.
JAZZ DEVELOPER

Did the application jar files get copied to the correct location?
Look for them under <install location>\tomcat\webapps
You should see jts.jar, qm.jar and I'm not sure the Requirements Manager jar would be but likely rm.jar

Also they can take time to deploy especially if this is the first time the server has been started since installing them.
Maybe you just need to wait a little longer.

3 answers



permanent link
Ralph Schoon (63.2k33646) | answered Nov 21 '13, 5:16 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
The URL for set up would be http://venkat-lt7.maa.corp.collab.net:9443/jts/setup . I have not tried the option to install into an existing Tomcat, however, that you get a page not found indicates that the applications did not start. If you start  up the server, the applications should be deployed, which you should notice in the blog. Since you don't mention any version numbers or operating systems, It is hard to be more specific, but on some OS's if you don't have the correct permissions set, you could get problems with the server start up.

Also, is the existing Tomcat compatible and did you install any Jazz Applications into it before? Can u ping the server with that host name?

I would suggest to
1. Setup a test system installing with the tomcat shipped with the product. Make sure you can start the server and access the URL's. Avoid Paths such as Program files, if installing on windows.
2. Consider to read the Deployment Wiki for additional hints: https://jazz.net/wiki/bin/view/Deployment/

It is almost impossible to cover all things that can go wrong, because there is so much infrastructure involved.

permanent link
Michael Afshar (7014) | answered Nov 21 '13, 12:17 p.m.
JAZZ DEVELOPER
Janarhadhanam,

The 9443 is a secure port number, but you are using http not https. Have you tried https://venkat-lt7.maa.corp.collab.net:9443/jts/?



permanent link
Janardhanam Venkat (611) | answered Nov 22 '13, 2:09 a.m.

All

Thanks for your update. General response for all the queries above

1. I was using a already installed Tomcat that was running Jama Software's requirement management tool. The directory structure under webapps are as follows that has all the jars of Jazz server and its subfolders. I don't see any issue here

/webapps/admin/...
/webapps/jts/...
/webapps/contour/...
/webapps/clmhelp/...
/webapps/jts.war
/webapps/clmhelp.war
/webapps/admin.war

2. My tomcat is very much running as I am able to access the following URL that is running Jama Soft
http://venkat-lt7.maa.corp.collab.net:8080/contour/

3. I also tried  http://venkat-lt7.maa.corp.collab.net:9443/jts/ & with HTTPS as mentioned in the doc https://venkat-lt7.maa.corp.collab.net:9443/jts/ 

4. I am using Windows 7 and Jazz server 4.0.4.

5. Someone mentioned that there may be Jazz already installed and the IBM Installation Manager is smart enough to find out that there is an existing version and throws an error message. I got the message, deleted the installed Jazz and installed second time successfully.

6. At least the product should have Jazz specific log files in tomcat

My last option left is to look at the wiki page  https://jazz.net/wiki/bin/view/Deployment/  mentioned by Ralph and then move on to other products.

-Venkat

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.