It's all about the answers!

Ask a question

Work Allocation Error


varun ibm (611722) | asked Oct 17 '13, 10:48 a.m.
 Hi All,

We are using RTC 4.0 and there are users with the following permissions

* Repository Permissions - JazzUsers
* License - Developer
* Process Role - we have created a custom role called 'Admin' with all permissions
*Administrator of the project area

However when these users are trying to modify their own work allocation or for other members of the project area
this is the error they receive
 
"You do not have permissions to change work assignments"
also for some users when they try to change their own work allocation , all the dates are striked off and it has a exclamatory red color mark which says "This date is not in valid range "

The strange thing is I have tried to replicate the same error in a different PA but those users do not have any issues.

I checked under process configuration > Project configuration > Configuration data >Planning> work environment
The box is "Unchecked" means the users should be able to modify and make changes being administrators of the PA.

What could be the problem ?

Accepted answer


permanent link
Stephanie Bagot (2.1k512) | answered Oct 21 '13, 10:49 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
The user should be able to edit their own work allocation without issue.
However, you must be a ProjectAdmin repository permission to edit the work allocation of other users (not just a project area admin).

See the following work items which are related:
https://jazz.net/jazz/web/projects/Jazz%20Foundation#action=com.ibm.team.workitem.viewWorkItem&id=180015
https://jazz.net/jazz/web/projects/Rational%20Team%20Concert#action=com.ibm.team.workitem.viewWorkItem&id=60786
varun ibm selected this answer as the correct answer

Comments
varun ibm commented Oct 21 '13, 11:15 a.m.

Thanks Stephanie , I went through the discussion on the links provided. But what is strange is I gave similar permissions to some users who have repository permissions as JazzUsers however project area admin. A few users are able to save these changes successfully but a few users get the error. It's seems strange that a few users are able to save changes  

2 other answers



permanent link
vishnudharan manivannan (1182241) | answered Oct 22 '13, 2:39 a.m.

Hi together,

I have come across the same trouble, where in users are not able to modify their own work allocations as well. Also when they try to do for their colleagues the dates are striked off as shown in the pic. Any solution ?


Comments
varun ibm commented Oct 22 '13, 6:08 a.m.

I have exactly the same error as well. The dates seems to be striked off. I am not sure what it means though. I would like to know the solution as well. 


varun ibm commented Oct 23 '13, 3:51 a.m.

Any comments on this ? 


vishnudharan manivannan commented Oct 23 '13, 3:52 a.m.

Hi Varun,


No not yet, I am still trying to find an answer.. 


vishnudharan manivannan commented Oct 25 '13, 4:37 a.m.

 

I am not sure for some users the years are displayed as 2000- 3000.. It's also odd that when they try to login from different desktops, then the dates populate fine. The java / browser versions are all the same. Still not able to find an answer as this problem is only for a set of users and not everyone..


Ralph Schoon commented Nov 28 '14, 7:55 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

This should have been posted as its own question. Don't put your questions in other users questions. You can put a link in here if you think you need to draw some attention from the subscribers of the post.


permanent link
Dorian Daumiller (362) | answered Nov 28 '14, 5:18 a.m.
I think that might be related to your dates being in german format (dd.mm.yyyy). Did you try setting your language to english?

Your answer


Register or to post your answer.