It's all about the answers!

Ask a question

error in implementing cross repository connection


shruti joshi (1003034) | asked Aug 31 '13, 3:15 a.m.
retagged Sep 03 '13, 4:42 p.m. by Amy Laird (16514)
hi,

  I am trying to establish communication between two different RTC 4.0 servers.
I had already enabled the SCM distributed property as TRUE and now I am trying to add one server as friend to another server. While doing this I am getting following errors:
   Server 1 (from which I am trying to add another server) : " An error occurred while requesting the root services document from server https://abc:9443/jazz/rootservices. Please check the URL and try again"

Server 2 (which I want to add as friend to another server) : " Public key not be decoded"

   I doing this cross implementation for the first time. can some one guide me for the same?

I am following " https://jazz.net/library/article/535" this article for the same.

Comments
Arne Bister commented Aug 31 '13, 11:33 a.m.
JAZZ DEVELOPER

You said these are RTC 4.0 servers. Have they been migrated from an earlier version or deliberately set up with the old style app name "jazz"?

If not, please try replacing "jazz" with "jts" in the root services URI.

Best,

Arne


shruti joshi commented Sep 02 '13, 12:26 a.m.

Hi Arne,

  I have tried this solution too, still I am getting same error as follows:

" ID CRJAZ2287E: an error occurred while communicating with the server at "https://abc.org:9443/jazz/rootservices: varify that the server is available and that there are no firewalls or other artifacts between these two endpoints that could present a confirmation dialog"

Same error is coming when I provide " https://abc.org:9443/jts/rootservices"

   Thanks and Regards
Shruti

Accepted answer


permanent link
Ralph Schoon (61.5k33643) | answered Sep 02 '13, 2:22 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Shruti,

please try your URL's in a browser. Compare them to your server's URL's and look for typos etc. You need to be able to reach the other server to make them friend.

Please be aware that the friend relationship is only necessary if you want to see the work items on the change set from any server.
shruti joshi selected this answer as the correct answer

Comments
shruti joshi commented Sep 02 '13, 3:31 a.m.

Hi Ralph,

   Can you please elaborate your point.....!!

Thanks and Regards
Shruti


Ralph Schoon commented Sep 02 '13, 3:41 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
  1. The friend relationship is not required for distributed SCM. It is only used when browsing to a work item linked to a change set, in case the work item is on the remote server. Distributed SCM works without the relationsip.
  2. Try the URL's in a browser, to make sure you can reach them. If you can and you still can't set up the friends relationship look at the server logs.
  3. From the public URI of each server, you should be able to determine if the context root is jazz or ccm (or any other custom context root) and also the correct port for the server.

shruti joshi commented Sep 02 '13, 7:59 a.m.

Hi raplh,

   I have tried what you have suggested but still my servers are not able to communicate with each other and either I am not able to access second URI from my RTC server.....



Ralph Schoon commented Sep 02 '13, 8:22 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Your description above is too short to help.

  1. If you are able to access the rootservice document with a browser for both servers, you have the information you need to friend the servers.
  2. If you can't reach the rootservice document with a browser, you have a wrong public URI or a network issue.
  3. If you can reach both rootservice documents from a machine in the network, but not from the two server machines you have a network issue



Ralph Schoon commented Sep 04 '13, 2:40 a.m. | edited Sep 04 '13, 2:40 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I just notices the URL's displayed above were completely wrong.

If you start with RTC 3.x or higher the public URI's would be https://<server>:<port>/ccm because you want to friend the CCM servers.

Your answer


Register or to post your answer.