It's all about the answers!

Ask a question

Need a list about known special characters in the password that aren't usable in Websphere


Joerg Aust (612) | asked Aug 14 '13, 9:28 a.m.

An user wasn't able to log on to a server using Websphere 7.0.0.19 but version 8.0.0.4 worked.

The log files contained this error message:

"msg="SECJ0118E: Authentication error during authentication for user".

or

"[LDAP: error code 49 - 80090308: LdapErr: DSID-0C0903A8, comment: AcceptSecurityContext error, data 52e, v1db1 ]"

Version 7.0.0.19 didn't accep "§".

Version 8.0.0.x shouldn't work "."

My recommendation to change it to ":" worked.

So there is a overview about problematic special characters needed. This would reduce the fixing effort.

Accepted answer


permanent link
John Carolan (71616) | answered Aug 14 '13, 9:42 a.m.
Hi Joerg,

I think the following document is what you are looking for:

http://pic.dhe.ibm.com/infocenter/wasinfo/v7r0/index.jsp?topic=%2Fcom.ibm.websphere.nd.doc%2Finfo%2Fae%2Fae%2Fcsec_chars.html

Regards,

John
Joerg Aust selected this answer as the correct answer

One other answer



permanent link
Anthony Kesterton (7.4k5172136) | answered Aug 14 '13, 9:50 a.m.
JAZZ DEVELOPER
I am guessing here - but if your system is configured to use an external LDAP (as it appears to be) - then it sounds like there might a be difference between your WAS 7 and 8 settings for LDAP.  You may want to track down LDAP settings on WAS.  Try the WAS Help on LDAP and user registry settings

anthony

Comments
Joerg Aust commented Aug 14 '13, 10:03 a.m.

Your guess is right. We use a LDAP and WAS version 7 has a different behaviour than 8.

We are able to ask and advise our user which special character can be used or not with John's link.

Your answer


Register or to post your answer.