It's all about the answers!

Ask a question

How to register a new web bundle with localhost?

Emma Nugee (1144) | asked Aug 12 '13, 9:51 a.m.

I am trying to create a new page as an extension to a jazz localhost server, following this guide:

However, when I try to launch a local test server with the web bundle added in, I get an error from RTC:

Description Resource Path Location Type
Referenced identifier '' in attribute 'id' cannot be found plugin.xml /com.example.hijazz.web line 22 Plug-in Problem

Just to cover all bases, I tried both with the jazz server already running and with out. When it was running, there is no change to the web ui; the page is not registered. When the server is not already running, then launching it through RTC does not enable me to access the server through a web browser.

If it's relevant, then for step 7 of the guide, "Add the web bundle to the server launch configuration", I created a new OSGI framework configuration as it was the only one I could find that gave me the option to include bundles from the workspace.

Could any one tell me what I should be doing to register a new web bundle, and deploy it to localhost?

Many thanks,

2 answers

permanent link
Chris Goldthorpe (4287) | answered Aug 12 '13, 1:59 p.m.
From your description it looks as though when you launch the web server with your extension the Web UI does not load. This would mean that something in your plug-in is causing an exception at server startup. When you launch the server check in the console for any errors, it is possible that the JavaScript compiler is failing to compile your JavaScript file. I have tried that example and the instructions do work.

Emma Nugee commented Aug 13 '13, 4:52 a.m.

Hi Chris, thank you for answering.

I don't think the problem is with javascript; having worked through the tutorial again, the warning appears as soon as the application "" is registered, before any javascript files are created. I've included a screenshot in an answer below.

I'm working on a new install of a localhost server, and have not done any configuration or set up in RTC other than to connect to localhost:9443/ccm and to create an OSGI framework, as mentioned above. Every other step I have taken is copying exactly what is done in the tutorial.

The console gets completely filled with errors, so many that I can't scroll up far enough to see the early ones. The majority of them seem to be about missing files; the first, for example, is

!MESSAGE CRRTC4670E The ClearQuest Importer cannot be run because the cqjni.jar file cannot be found. 

Is there perhaps some form of set up I am missing? I did notice, for example, that step 7 assumed an already existing launch configuration which I don't have.

permanent link
Emma Nugee (1144) | answered Aug 13 '13, 4:54 a.m.
  Screenshot of plugin.xml

The location of the warning in the plugin.xml file. The warning reads: "Referenced identifier '' in attribute 'id' cannot be found."

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.